logo

pleroma

My custom branche(s) on git.pleroma.social/pleroma/pleroma git clone https://hacktivis.me/git/pleroma.git

relayd.conf (1676B)


  1. #
  2. # Default relayd.conf file for Pleroma on OpenBSD
  3. # Simple installation instructions:
  4. # 1. Place in /etc
  5. # 2. Replace <ipaddr> with your public IPv4 address
  6. # 3. If using IPv6i, uncomment IPv6 lines and replace <ip6addr> with your public IPv6 address
  7. # 4. Check file using 'doas relayd -n'
  8. # 5. Reload/start relayd
  9. # # doas rcctl enable relayd
  10. # # doas rcctl start relayd
  11. #
  12. ext_inet="<ipaddr>"
  13. #ext_inet6="<ip6addr>"
  14. table <pleroma_server> { 127.0.0.1 }
  15. table <httpd_server> { 127.0.0.1 }
  16. http protocol plerup { # Protocol for upstream pleroma server
  17. #tcp { nodelay, sack, socket buffer 65536, backlog 128 } # Uncomment and adjust as you see fit
  18. tls ciphers "ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA0-POLY1305"
  19. tls ecdhe secp384r1
  20. # Forward some paths to the local server (as pleroma won't respond to them as you might want)
  21. pass request quick path "/robots.txt" forward to <httpd_server>
  22. # Append a bunch of headers
  23. match request header append "X-Forwarded-For" value "$REMOTE_ADDR" # This two header and the next one are not strictl required by pleroma but adding them won't hurt
  24. match request header append "X-Forwarded-By" value "$SERVER_ADDR:$SERVER_PORT"
  25. match request header append "Connection" value "upgrade"
  26. }
  27. relay wwwtls {
  28. listen on $ext_inet port https tls # Comment to disable listening on IPv4
  29. # listen on $ext_inet6 port https tls # Comment to disable listening on IPv6
  30. protocol plerup
  31. forward to <pleroma_server> port 4000 check http "/" code 200
  32. forward to <httpd_server> port 80 check http "/robots.txt" code 200
  33. }