logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

ultrasharp-cursor-theme-9999.ebuild (622B)


  1. # Copyright 2022-2024 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3 ninja-utils
  5. DESCRIPTION="Precision and speed oriented cursor theme"
  6. HOMEPAGE="https://hacktivis.me/projects/ultrasharp-cursor-theme"
  7. EGIT_REPO_URI="https://hacktivis.me/git/ultrasharp-cursor-theme.git"
  8. LICENSE="CC-BY-SA-4.0"
  9. SLOT="0"
  10. BDEPEND="
  11. || (
  12. x11-apps/xcursorgen
  13. x11-apps/xcursorgen-nox
  14. )
  15. media-gfx/imagemagick
  16. "
  17. src_configure() {
  18. ./configure PREFIX=/usr || die
  19. }
  20. src_compile() {
  21. eninja
  22. }
  23. src_install() {
  24. DESTDIR="${ED}" eninja install
  25. }