logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

adwaita-qt-1.4.2-r1.ebuild (863B)


  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake
  5. DESCRIPTION="A style to bend Qt applications to look like they belong into GNOME Shell"
  6. HOMEPAGE="https://github.com/FedoraQt/adwaita-qt"
  7. SRC_URI="
  8. https://github.com/FedoraQt/${PN}/archive/${PV}/${P}.tar.gz
  9. https://github.com/FedoraQt/adwaita-qt/pull/196/commits/bf7c2c05d705bf3f654b1648a0300b09a5925c6c.patch -> adwaita-qt-1.4.2-dbus-cleanup.patch
  10. "
  11. LICENSE="GPL-2 LGPL-2"
  12. SLOT="0"
  13. KEYWORDS="amd64 ~arm64 ~ppc64 x86"
  14. IUSE="gnome"
  15. DEPEND="
  16. dev-qt/qtcore:5
  17. dev-qt/qtgui:5
  18. dev-qt/qtwidgets:5
  19. dev-qt/qtx11extras:5
  20. "
  21. RDEPEND="${DEPEND}"
  22. PDEPEND="gnome? ( x11-themes/QGnomePlatform )"
  23. PATCHES=(
  24. "${DISTDIR}/adwaita-qt-1.4.2-dbus-cleanup.patch"
  25. )
  26. src_configure() {
  27. local mycmakeargs=(
  28. -DUSE_QT6=false
  29. )
  30. cmake_src_configure
  31. }