logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

svte-9999.ebuild (620B)


  1. # Copyright 2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit git-r3
  5. DESCRIPTION="Simple-ass VTE-based (I know) terminal"
  6. HOMEPAGE="https://hacktivis.me/git/svte/"
  7. EGIT_REPO_URI="https://hacktivis.me/git/svte.git"
  8. EGIT_MIN_CLONE_TYPE="single+tags"
  9. LICENSE="CC-BY-SA-4.0"
  10. SLOT="0"
  11. DEPEND="
  12. x11-libs/vte
  13. x11-libs/gtk+:3=
  14. "
  15. RDEPEND="${DEPEND}"
  16. src_compile() {
  17. emake \
  18. CC="${CC:-cc}" \
  19. CFLAGS="${CFLAGS:--02 -Wall -Wextra}" \
  20. LDFLAGS="${LDFLAGS}" \
  21. PREFIX="/usr"
  22. }
  23. src_install() {
  24. emake \
  25. DESTDIR="${D}" \
  26. PREFIX="/usr" \
  27. install
  28. einstalldocs
  29. }