logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

pangoterm-0.0_pre621.ebuild (677B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. # one-indexed: [0, 0, pre, 621]
  5. MY_PV="$(ver_cut 4)"
  6. DESCRIPTION="A GTK/Pango-based terminal that uses libvterm to provide terminal emulation"
  7. HOMEPAGE="http://www.leonerd.org.uk/code/pangoterm/"
  8. SRC_URI="https://bazaar.launchpad.net/~leonerd/pangoterm/trunk/tarball/${MY_PV} -> ${P}.tar.gz"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. IUSE=""
  13. DEPEND="
  14. >=dev-libs/libvterm-0.1.3
  15. x11-libs/cairo:=
  16. x11-libs/gtk+:2=
  17. "
  18. RDEPEND="${DEPEND}"
  19. S="${WORKDIR}/~leonerd/pangoterm/trunk/"
  20. src_install() {
  21. emake PREFIX="/usr" DESTDIR="${D}" install
  22. dodoc pangoterm.cfg
  23. }