logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

xdg-utils-1.1.3-r1.ebuild (2202B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. MY_P="${P/_/-}"
  6. DESCRIPTION="Portland utils for cross-platform/cross-toolkit/cross-desktop interoperability"
  7. HOMEPAGE="https://www.freedesktop.org/wiki/Software/xdg-utils/"
  8. #SRC_URI="https://dev.gentoo.org/~johu/distfiles/${P}.tar.xz"
  9. #SRC_URI="https://people.freedesktop.org/~rdieter/${PN}/${MY_P}.tar.gz
  10. # https://dev.gentoo.org/~ssuominen/${P}-patchset-1.tar.xz"
  11. SRC_URI="https://portland.freedesktop.org/download/${MY_P}.tar.gz"
  12. LICENSE="MIT"
  13. SLOT="0"
  14. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 "
  15. IUSE="dbus doc gnome X"
  16. RDEPEND="
  17. dev-util/desktop-file-utils
  18. dev-perl/File-MimeInfo
  19. x11-misc/shared-mime-info
  20. dbus? (
  21. sys-apps/dbus
  22. gnome? (
  23. dev-perl/Net-DBus
  24. dev-perl/X11-Protocol
  25. )
  26. )
  27. X? (
  28. x11-apps/xprop
  29. x11-apps/xset
  30. )
  31. "
  32. DEPEND=">=app-text/xmlto-0.0.26-r1[text(+)]"
  33. DOCS=( README RELEASE_NOTES TODO ) # ChangeLog is bogus, see git instead
  34. RESTRICT="test" # Disabled because of sandbox violation(s)
  35. PATCHES=(
  36. "${FILESDIR}"/xdg-utils-1.1.3-xdg-open-pcmanfm.patch
  37. )
  38. #S=${WORKDIR}/${MY_P}
  39. src_prepare() {
  40. default
  41. # If you choose to do git snapshot instead of patchset, you need to remember
  42. # to run `autoconf` in ./ and `make scripts-clean` in ./scripts/ to refresh
  43. # all the files
  44. if [[ -d "${WORKDIR}/patch" ]]; then
  45. eapply "${WORKDIR}/patch"
  46. fi
  47. eautoreconf
  48. }
  49. src_configure() {
  50. export ac_cv_path_XMLTO="$(type -P xmlto) --skip-validation" #502166
  51. default
  52. }
  53. src_install() {
  54. default
  55. newdoc scripts/xsl/README README.xsl
  56. use doc && dodoc -r scripts/html
  57. # Install default XDG_DATA_DIRS, bug #264647
  58. echo XDG_DATA_DIRS=\"${EPREFIX}/usr/local/share\" > 30xdg-data-local
  59. echo 'COLON_SEPARATED="XDG_DATA_DIRS XDG_CONFIG_DIRS"' >> 30xdg-data-local
  60. doenvd 30xdg-data-local
  61. echo XDG_DATA_DIRS=\"${EPREFIX}/usr/share\" > 90xdg-data-base
  62. echo XDG_CONFIG_DIRS=\"${EPREFIX}/etc/xdg\" >> 90xdg-data-base
  63. doenvd 90xdg-data-base
  64. }
  65. pkg_postinst() {
  66. [[ -x $(type -P gtk-update-icon-cache) ]] \
  67. || elog "Install dev-util/gtk-update-icon-cache for the gtk-update-icon-cache command."
  68. }