logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

tabbed-0.6.ebuild (962B)


  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit savedconfig toolchain-funcs
  5. DESCRIPTION="Simple generic tabbed fronted to xembed aware applications"
  6. HOMEPAGE="https://tools.suckless.org/tabbed/"
  7. SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="x11-libs/libX11"
  13. DEPEND="
  14. x11-base/xorg-proto
  15. ${RDEPEND}
  16. "
  17. src_prepare() {
  18. sed config.mk \
  19. -e '/^CC/d' \
  20. -e 's|/usr/local|/usr|g' \
  21. -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
  22. -e 's|^LDFLAGS.*|LDFLAGS += $(CFLAGS) $(LIBS)|g' \
  23. -e 's|^LIBS.*|LIBS = -lX11|g' \
  24. -e 's|{|(|g;s|}|)|g' \
  25. -i || die
  26. sed Makefile \
  27. -e 's|{|(|g;s|}|)|g' \
  28. -e '/^[[:space:]]*@echo/d' \
  29. -e 's|^ @| |g' \
  30. -i || die
  31. restore_config config.h
  32. default
  33. }
  34. src_compile() {
  35. emake CC=$(tc-getCC)
  36. }
  37. src_install() {
  38. default
  39. save_config config.h
  40. }