logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

qarma-9999.ebuild (574B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit git-r3 qmake-utils
  5. DESCRIPTION="Zenity Clone for Qt5 (lanodan's branch)"
  6. HOMEPAGE="https://github.com/lanodan/qarma"
  7. EGIT_REPO_URI="https://github.com/lanodan/qarma"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS=""
  11. IUSE="+dbus"
  12. DEPEND="
  13. dev-qt/qtcore:5
  14. dev-qt/qtgui:5
  15. dev-qt/qtwidgets:5
  16. dev-qt/qtx11extras:5
  17. dbus? ( dev-qt/qtdbus:5 )
  18. "
  19. RDEPEND="${DEPEND}"
  20. src_configure() {
  21. eqmake5 $(usex dbus "" "CONFIG+=DISABLE_DBUS")
  22. }
  23. src_install() {
  24. dobin qarma
  25. }