logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gtk3-nocsd-9999.ebuild (618B)


  1. # Copyright 1999-2018 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit multilib git-r3
  5. DESCRIPTION="A hack to disable gtk3 client-side decorations"
  6. HOMEPAGE="https://github.com/naufalfachrian/gtk3-nocsd"
  7. EGIT_REPO_URI="https://github.com/naufalfachrian/gtk3-nocsd.git"
  8. SLOT="0"
  9. KEYWORDS=""
  10. IUSE=""
  11. LICENSE="GPL-2"
  12. DEPEND="x11-libs/gtk+:3"
  13. RDEPEND="${DEPEND}"
  14. src_install() {
  15. emake prefix="${D}/usr" libdir="${D}/usr/$(get_libdir)" install
  16. dodir /etc/env.d
  17. einfo "Add to your .profile:\nGTK_CSD=0\nLD_PRELOAD=${EROOT%/}/usr/$(get_libdir)/libgtk3-nocsd.so.0"
  18. }