logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

fltk-1.4.9999.ebuild (2364B)


  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake-multilib flag-o-matic git-r3 xdg-utils
  5. DESCRIPTION="C++ user interface toolkit for X and OpenGL"
  6. HOMEPAGE="https://www.fltk.org/"
  7. EGIT_REPO_URI="https://github.com/fltk/fltk"
  8. SLOT="1"
  9. LICENSE="FLTK LGPL-2"
  10. KEYWORDS=""
  11. IUSE="cairo debug doc examples games +opengl static-libs +threads +wayland +X +xft +xinerama"
  12. REQUIRED_USE="xinerama? ( X ) xft? ( X )"
  13. RDEPEND="
  14. >=media-libs/libpng-1.2:0=[${MULTILIB_USEDEP}]
  15. sys-libs/zlib[${MULTILIB_USEDEP}]
  16. virtual/jpeg:0=[${MULTILIB_USEDEP}]
  17. cairo? ( x11-libs/cairo[${MULTILIB_USEDEP},X] )
  18. games? ( !sys-block/blocks )
  19. opengl? (
  20. virtual/glu[${MULTILIB_USEDEP}]
  21. virtual/opengl[${MULTILIB_USEDEP}]
  22. )
  23. wayland? (
  24. x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
  25. x11-libs/pango
  26. dev-libs/wayland
  27. gui-libs/libdecor
  28. opengl? ( media-libs/glew:0 )
  29. )
  30. X? (
  31. x11-libs/libICE[${MULTILIB_USEDEP}]
  32. x11-libs/libSM[${MULTILIB_USEDEP}]
  33. x11-libs/libXcursor[${MULTILIB_USEDEP}]
  34. x11-libs/libXext[${MULTILIB_USEDEP}]
  35. x11-libs/libXfixes[${MULTILIB_USEDEP}]
  36. x11-libs/libXt[${MULTILIB_USEDEP}]
  37. )
  38. xft? ( x11-libs/libXft[${MULTILIB_USEDEP}] )
  39. xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
  40. "
  41. DEPEND="
  42. ${RDEPEND}
  43. virtual/pkgconfig
  44. wayland? ( dev-libs/wayland-protocols )
  45. X? ( x11-base/xorg-proto )
  46. doc? ( app-doc/doxygen )
  47. "
  48. DOCS=(
  49. ANNOUNCEMENT
  50. CHANGES.txt
  51. CHANGES_1.0.txt
  52. CHANGES_1.1.txt
  53. CHANGES_1.3.txt
  54. CREDITS.txt
  55. README.Android.md
  56. README.CMake.txt
  57. README.Cairo.txt
  58. README.IDE.txt
  59. README.Pico.txt
  60. README.Unix.txt
  61. README.Windows.txt
  62. README.abi-version.txt
  63. README.bundled-libs.txt
  64. README.macOS.md
  65. README.md
  66. README.txt
  67. )
  68. pkg_setup() {
  69. unset FLTK_LIBDIRS
  70. }
  71. src_prepare() {
  72. rm -rf zlib jpeg png || die
  73. cmake_src_prepare
  74. multilib_src_prepare
  75. }
  76. multilib_src_configure() {
  77. local mycmakeargs=(
  78. -DOPTION_BUILD_SHARED_LIBS=ON
  79. -DOPTION_CAIRO=ON
  80. -DOPTION_CAIROEXT=ON
  81. -DOPTION_PANGO=ON
  82. -DOPTION_USE_SYSTEM_ZLIB=ON
  83. -DOPTION_USE_SYSTEM_LIBJPEG=ON
  84. -DOPTION_USE_SYSTEM_LIBPNG=ON
  85. -DOPTION_USE_SYSTEM_LIBDECOR=ON
  86. -DOPTION_USE_WAYLAND=$(usex wayland)
  87. )
  88. # -DOpenGL_GL_PREFERENCE=GLVND
  89. cmake_src_configure
  90. }
  91. pkg_postinst() {
  92. xdg_desktop_database_update
  93. xdg_icon_cache_update
  94. }
  95. pkg_postrm() {
  96. xdg_desktop_database_update
  97. xdg_icon_cache_update
  98. }