logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

xwayland-9999.ebuild (1975B)


  1. # Copyright 2021-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit meson git-r3
  5. DESCRIPTION="Standalone X server running under Wayland"
  6. HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
  7. EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
  8. IUSE="selinux video_cards_nvidia unwind xcsecurity"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. DEPEND="
  12. >=x11-libs/pixman-0.27.2
  13. dev-libs/libbsd
  14. >=x11-libs/libXfont2-2.0.1
  15. dev-libs/openssl:=
  16. dev-libs/wayland
  17. video_cards_nvidia? ( gui-libs/egl-wayland )
  18. >=x11-libs/libXdmcp-1.0.2
  19. >=x11-libs/libdrm-2.4.89
  20. >=media-libs/libepoxy-1.5.4[X,egl(+)]
  21. >=media-libs/mesa-21.1[X(+),egl(+),gbm(+)]
  22. >=x11-libs/libxshmfence-1.1
  23. >=x11-libs/libXau-1.0.4
  24. media-libs/libglvnd[X]
  25. unwind? ( sys-libs/libunwind )
  26. >=dev-libs/wayland-protocols-1.18
  27. media-fonts/font-util
  28. x11-libs/libxkbfile
  29. >=x11-libs/xtrans-1.3.5
  30. x11-base/xorg-proto
  31. >=x11-misc/xkeyboard-config-2.4.1-r3
  32. x11-libs/libxcvt
  33. "
  34. RDEPEND="
  35. ${DEPEND}
  36. x11-apps/xkbcomp
  37. !<=x11-base/xorg-server-1.20.11
  38. selinux? ( sec-policy/selinux-xserver )
  39. "
  40. BDEPEND="
  41. sys-devel/flex
  42. dev-util/wayland-scanner
  43. "
  44. src_prepare() {
  45. default
  46. sed -i '/install_man(/,/))/d' meson.build \
  47. || die "Failed to remove Xserver.1 install target"
  48. sed -i '/install_data/,/)/d' dix/meson.build \
  49. || die "Failed to remove protocols.txt install target"
  50. }
  51. src_configure() {
  52. local emesonargs=(
  53. $(meson_use selinux xselinux)
  54. $(meson_use unwind libunwind)
  55. $(meson_use xcsecurity)
  56. $(meson_use video_cards_nvidia xwayland_eglstream)
  57. -Ddpms=true
  58. -Ddri3=true
  59. -Ddtrace=false
  60. -Dglamor=true
  61. -Dglx=true
  62. -Dipv6=true
  63. -Dsecure-rpc=false
  64. -Dscreensaver=true
  65. -Dsha1=libcrypto
  66. -Dxace=true
  67. -Dxdmcp=true
  68. -Dxinerama=true
  69. -Dxvfb=false
  70. -Dxnest=false
  71. -Dxwayland-path="${EPREFIX}"/usr/bin
  72. -Dxorg=false
  73. -Dxwayland=true
  74. )
  75. meson_src_configure
  76. }
  77. src_install() {
  78. dosym ../bin/Xwayland /usr/libexec/Xwayland
  79. meson_src_install
  80. }