logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

tipidee-0.0.5.0.ebuild (871B)


  1. # Copyright 2024 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit toolchain-funcs edo
  5. DESCRIPTION="HTTP 1.1 webserver, serving static files and CGI/NPH"
  6. HOMEPAGE="https://www.skarnet.org/software/tipidee/"
  7. SRC_URI="https://www.skarnet.org/software/tipidee/${P}.tar.gz"
  8. LICENSE="ISC"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="static"
  12. DEPEND=">=dev-libs/skalibs-2.14.1.1:="
  13. RDEPEND="${DEPEND}"
  14. DOCS=( doc examples )
  15. src_prepare() {
  16. default
  17. sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
  18. }
  19. src_configure() {
  20. tc-export AR CC RANLIB
  21. edo ./configure \
  22. ${CTARGET:+--target=${CTARGET}} \
  23. --host="${CHOST}" \
  24. --prefix="${EPREFIX}"/usr \
  25. --sysconfdir="${EPREFIX}"/etc \
  26. --with-sysdeps="/usr/$(get_libdir)/skalibs" \
  27. --disable-static \
  28. $(use_enable static static-libc)
  29. }