logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

ublock-1.19.6.ebuild (928B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. MY_XPINAME="uBlock0_${PV}.firefox"
  5. DESCRIPTION="An efficient blocker for Chromium and Firefox. Fast and lean"
  6. HOMEPAGE="https://github.com/gorhill/uBlock"
  7. SRC_URI="https://github.com/gorhill/uBlock/releases/download/${PV}/${MY_XPINAME}.xpi"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. S="${WORKDIR}"
  13. src_unpack() {
  14. cp "${DISTDIR}/${MY_XPINAME}.xpi" . || die
  15. }
  16. src_install() {
  17. # See https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/Distribution_options/Sideloading_add-ons#Installation_using_the_standard_extension_folders
  18. insinto "/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/"
  19. # Use the extension id found in the manifest.json for the filename and add .xpi
  20. newins "${MY_XPINAME}.xpi" "uBlock0@raymondhill.net.xpi"
  21. }