logo

overlay

My (experimental) gentoo overlay

ublock-1.18.16.ebuild (928B)


      1 # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 MY_XPINAME="uBlock0_${PV}.firefox"
      7 
      8 DESCRIPTION="An efficient blocker for Chromium and Firefox. Fast and lean"
      9 HOMEPAGE="https://github.com/gorhill/uBlock"
     10 SRC_URI="https://github.com/gorhill/uBlock/releases/download/${PV}/${MY_XPINAME}.xpi"
     11 
     12 LICENSE="GPL-2"
     13 SLOT="0"
     14 KEYWORDS="~amd64 ~x86"
     15 IUSE=""
     16 
     17 S="${WORKDIR}"
     18 
     19 src_unpack() {
     20 	cp "${DISTDIR}/${MY_XPINAME}.xpi" . || die
     21 }
     22 
     23 src_install() {
     24 	# See https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/Distribution_options/Sideloading_add-ons#Installation_using_the_standard_extension_folders
     25 	insinto "/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/"
     26 	# Use the extension id found in the manifest.json for the filename and add .xpi
     27 	newins "${MY_XPINAME}.xpi" "uBlock0@raymondhill.net.xpi"
     28 }