logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

stagit-0.9.4.ebuild (587B)


  1. # Copyright 2016-2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DESCRIPTION="static git page generator"
  5. HOMEPAGE="https://git.codemadness.org/stagit/"
  6. SRC_URI="https://codemadness.org/releases/stagit/${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="~amd64"
  10. IUSE=""
  11. DEPEND="dev-libs/libgit2:="
  12. RDEPEND="${DEPEND}"
  13. src_configure() {
  14. sed -i \
  15. -e "/^.POSIX:/d" \
  16. -e "s;^PREFIX =.*;PREFIX ?= ${EPREFIX}/usr;" \
  17. -e "s;^MANPREFIX = .*;MANPREFIX = ${EPREFIX}/usr/share/man;" \
  18. "${S}/Makefile" || die
  19. }