logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

pleroma-2.4.2.ebuild (1067B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit mix
  5. DESCRIPTION="ActivityPub social networking software compatible with other Fediverse software"
  6. HOMEPAGE="https://pleroma.social/"
  7. SRC_URI="https://git.pleroma.social/pleroma/pleroma/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
  8. S="${WORKDIR}/${PN}-v${PV}"
  9. LICENSE="AGPL-3 CC-BY-SA-4.0 CC-BY-4.0"
  10. SLOT="otp"
  11. KEYWORDS="~amd64"
  12. IUSE="imagemagick ffmpeg exiftool"
  13. BDEPEND="
  14. dev-lang/erlang:=
  15. dev-lang/elixir:=
  16. dev-util/cmake
  17. dev-util/rebar
  18. dev-elixir/hex
  19. "
  20. DEPEND="
  21. sys-libs/ncurses:=
  22. sys-apps/file
  23. "
  24. RDEPEND="
  25. ${DEPEND}
  26. imagemagick? ( media-gfx/imagemagick )
  27. ffmpeg? ( media-video/ffmpeg )
  28. exiftool? ( media-libs/exiftool )
  29. "
  30. src_unpack() {
  31. default
  32. cd "${S}" || die
  33. emix deps.get --only prod
  34. }
  35. src_prepare() {
  36. default
  37. echo "import Mix.Config" > config/prod.secret.exs || die
  38. }
  39. src_compile() {
  40. mkdir -p pleroma || die
  41. emix release --path pleroma
  42. }
  43. src_install() {
  44. insinto /opt/
  45. doins -r pleroma
  46. }