logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

bloat-9999.ebuild (711B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="Web client for Pleroma and Mastodon"
  6. HOMEPAGE="https://git.freesoftwareextremist.com/bloat/"
  7. EGIT_REPO_URI="https://git.freesoftwareextremist.com/bloat"
  8. EGIT_MIN_CLONE_TYPE="single+tags"
  9. # /: CC0-1.0
  10. # /vendor/…/gorilla/mux: BSD
  11. # /vendor/…/linkheader: MIT
  12. # /mastodon (go-mastodon): MIT
  13. LICENSE="CC0-1.0 BSD MIT"
  14. SLOT="0"
  15. KEYWORDS=""
  16. # TODO: de-vendor modules by making them proper dev-go/ dependencies
  17. BDEPEND=">=dev-lang/go-1.11"
  18. DOCS=( README bloat.conf )
  19. src_configure() {
  20. sed -i 's;^PREFIX=.*;PREFIX=/usr;' Makefile || die
  21. }