logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

wine-0-r8.ebuild (841B)


  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
  5. SLOT="0"
  6. KEYWORDS="amd64 x86"
  7. IUSE="+abi_x86_32 +abi_x86_64 staging"
  8. REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
  9. # Note, the ordering here is intentional, to take advantage of the short-circuit
  10. # logic of portage, to enforce wine-vanilla as default for new users. The idea
  11. # behind this is that some USE flags may pull in 3rd-party patchsets, so default
  12. # of vanilla prevents that.
  13. RDEPEND="
  14. staging? ( || (
  15. app-emulation/wine-staging[staging]
  16. ) )
  17. || (
  18. app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
  19. app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
  20. app-emulation/wine-wayland[abi_x86_32=,abi_x86_64=]
  21. )
  22. !app-emulation/wine:0
  23. "