logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://anongit.hacktivis.me/git/overlay.git/

libudev-zero-1.0.3.ebuild (696B)


  1. # Copyright 2024 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit toolchain-funcs
  5. DESCRIPTION="Daemonless replacement for libudev"
  6. HOMEPAGE="https://github.com/illiliti/libudev-zero"
  7. SRC_URI="https://github.com/illiliti/libudev-zero/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="ISC"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="static-libs"
  12. RDEPEND="!sys-apps/systemd-utils[udev]"
  13. src_compile() {
  14. emake libudev.so.1
  15. use static-libs && emake AR="$(tc-getAR)" libudev.a
  16. }
  17. src_install() {
  18. emake DESTDIR="${D}" PREFIX=/usr install-shared
  19. use static-libs && emake DESTDIR="${D}" PREFIX=/usr install-static
  20. }