logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

edk2-tools-202305.ebuild (1019B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="tools for processing UEFI firmware content (EfiRom, GenFfs, ...)"
  5. HOMEPAGE="https://github.com/tianocore/edk2"
  6. SRC_URI="https://github.com/tianocore/edk2/archive/edk2-stable${PV}.tar.gz"
  7. S="${WORKDIR}/edk2-edk2-stable${PV}/BaseTools"
  8. LICENSE="BSD-2 MIT"
  9. SLOT="0"
  10. KEYWORDS="-* ~amd64"
  11. IUSE=""
  12. # util-linux for libuuid.so
  13. DEPEND="sys-apps/util-linux"
  14. RDEPEND="${DEPEND}"
  15. # Includes manuals but RTF-formatted
  16. BDEPEND="sys-apps/help2man"
  17. src_prepare() {
  18. default
  19. # Remove brotli which pulls submodules
  20. sed -i -e '/BrotliCompress/d' Source/C/GNUmakefile || die
  21. }
  22. src_compile() {
  23. emake -C Source/C \
  24. BUILD_CC="${CC}" \
  25. BUILD_CXX="${CXX}" \
  26. BUILD_AS="${AS}" \
  27. BUILD_AR="${AR}" \
  28. BUILD_LD="${LD}"
  29. }
  30. src_install() {
  31. dobin Source/C/bin/*
  32. for bin in Source/C/bin/*; do
  33. help2man -s1 -n "$(basename "$bin")" -N -o "$bin".1 $bin
  34. doman "$bin".1
  35. done
  36. }