logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

pnut-9999.ebuild (552B)


  1. # Copyright 2024 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="Self-Compiling C Transpiler Targeting Human-Readable POSIX Shell"
  6. HOMEPAGE="https://pnut.sh/"
  7. EGIT_REPO_URI="https://github.com/udem-dlteam/pnut"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. src_prepare() {
  12. default
  13. sed -i 's;gcc;$(CC);' Makefile || die
  14. }
  15. src_compile() {
  16. emake pnut-sh pnut.sh
  17. }
  18. src_install() {
  19. einstalldocs
  20. newbin build/pnut-sh pnut
  21. dobin build/pnut.sh
  22. }