logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gettext-0.3.2-r3.ebuild (1408B)


  1. # Copyright 2022-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit toolchain-funcs multilib-minimal
  5. DESCRIPTION="Stub and/or lightweight replacements of the GNU gettext suite"
  6. HOMEPAGE="https://github.com/sabotage-linux/gettext-tiny"
  7. SRC_URI="https://github.com/sabotage-linux/gettext-tiny/archive/refs/tags/v${PV}.tar.gz -> gettext-tiny-${PV}.tar.gz"
  8. S="${WORKDIR}/gettext-tiny-${PV}/"
  9. LICENSE="MIT"
  10. SLOT="tiny"
  11. KEYWORDS="~amd64"
  12. IUSE="shim"
  13. RDEPEND="!sys-devel/gettext:0"
  14. PATCHES=(
  15. "${FILESDIR}"/gettext-0.3.2-respect-CFLAGS.patch
  16. "${FILESDIR}"/gettext-0.3.2-xgettext-version-output.patch
  17. "${FILESDIR}"/gettext-0.3.2-autopoint-parenthesis.patch
  18. )
  19. DOCS=( README.md docs )
  20. src_prepare() {
  21. default
  22. # Needs to be set early, otherwise scripts like autopoint have a wrong prefix value
  23. sed -i "s;^prefix=.*;prefix=${EPREFIX}/usr;" Makefile || die
  24. multilib_copy_sources
  25. }
  26. multilib_src_compile() {
  27. tc-export AR RANLIB CC
  28. emake
  29. }
  30. multilib_src_install() {
  31. local libintl_type
  32. if use shim ; then
  33. if use elibc_musl ; then
  34. libintl_type=MUSL
  35. else
  36. libintl_type=NOOP
  37. fi
  38. else
  39. # If they don't want the shim (e.g. glibc users who have their own libintl),
  40. # don't install a libintl and just install the binaries.
  41. libintl_type=NONE
  42. fi
  43. emake LIBINTL="${libintl_type}" DESTDIR="${D}" libdir="${EPREFIX}/usr/$(get_libdir)" install
  44. }