logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gettext-0.3.2-r2.ebuild (1236B)


  1. # Copyright 2022-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit toolchain-funcs
  5. DESCRIPTION="Stub and/or lightweight replacements of the GNU gettext suite"
  6. HOMEPAGE="https://github.com/sabotage-linux/gettext-tiny"
  7. SRC_URI="https://github.com/sabotage-linux/gettext-tiny/archive/refs/tags/v${PV}.tar.gz -> gettext-tiny-${PV}.tar.gz"
  8. S="${WORKDIR}/gettext-tiny-${PV}/"
  9. LICENSE="MIT"
  10. SLOT="tiny"
  11. KEYWORDS="~amd64"
  12. IUSE="shim"
  13. RDEPEND="!sys-devel/gettext:0"
  14. PATCHES=(
  15. "${FILESDIR}"/${P}-respect-CFLAGS.patch
  16. "${FILESDIR}"/${P}-xgettext-version-output.patch
  17. )
  18. DOCS=( README.md docs )
  19. src_prepare() {
  20. default
  21. # Needs to be set early, otherwise scripts like autopoint have a wrong prefix value
  22. sed -i "s;^prefix=.*;prefix=${EPREFIX}/usr;" Makefile || die
  23. }
  24. src_compile() {
  25. tc-export AR RANLIB CC
  26. emake
  27. }
  28. src_install() {
  29. local libintl_type
  30. if use shim ; then
  31. if use elibc_musl ; then
  32. libintl_type=MUSL
  33. else
  34. libintl_type=NOOP
  35. fi
  36. else
  37. # If they don't want the shim (e.g. glibc users who have their own libintl),
  38. # don't install a libintl and just install the binaries.
  39. libintl_type=NONE
  40. fi
  41. emake LIBINTL="${libintl_type}" DESTDIR="${D}" install
  42. }