logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gcc-x86_64-bunnix-13.0.0.9999.ebuild (1151B)


  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{10..12} )
  5. inherit toolchain
  6. EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/gcc"
  7. EGIT_BRANCH="bunnix"
  8. BDEPEND=">=sys-devel/binutils-x86_64-bunnix-2.30"
  9. #if [[ ${CATEGORY} != cross-* ]] ; then
  10. # # Technically only if USE=hardened *too* right now, but no point in complicating it further.
  11. # # If GCC is enabling CET by default, we need glibc to be built with support for it.
  12. # # bug #830454
  13. # RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
  14. # DEPEND="${RDEPEND}"
  15. # BDEPEND=">=${CATEGORY}/binutils-2.30[cet(-)?]"
  16. #fi
  17. RESTRICT="test"
  18. export CTARGET="x86_64-bunnix"
  19. src_unpack() {
  20. git-r3_src_unpack
  21. # Needed for gcc --version to include the upstream commit used
  22. # rather than only the commit after we apply our patches.
  23. # It includes both with this.
  24. echo "${EGIT_VERSION}" > "${S}"/gcc/REVISION || die
  25. default
  26. }
  27. src_prepare() {
  28. local p upstreamed_patches=(
  29. # add them here
  30. )
  31. for p in "${upstreamed_patches[@]}"; do
  32. rm -v "${WORKDIR}/patch/${p}" || die
  33. done
  34. toolchain_src_prepare
  35. eapply_user
  36. }