logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

skeud-9999.ebuild (729B)


  1. # Copyright 2021-2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="Simple and portable utilities to deal with user accounts (su, login)"
  6. HOMEPAGE="https://hacktivis.me/git/skeud"
  7. EGIT_REPO_URI="https://hacktivis.me/git/skeud.git"
  8. LICENSE="MPL-2.0"
  9. SLOT="0"
  10. IUSE="test"
  11. RESTRICT="!test? ( test )"
  12. RDEPEND="virtual/libcrypt:="
  13. DEPEND="${RDEPEND}"
  14. BDEPEND="
  15. test? (
  16. dev-libs/atf
  17. dev-util/kyua
  18. )
  19. "
  20. src_install() {
  21. emake install DESTDIR="${D}" PREFIX='/opt/lanodan' SYS_BINDIR='/opt/lanodan/bin'
  22. # before 50baselayout
  23. newenvd - 40skeud <<-EOF
  24. PATH="/opt/lanodan/bin"
  25. MANPATH="/opt/lanodan/share/man"
  26. EOF
  27. }