logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

seatd-0.4.0.ebuild (951B)


  1. # Copyright 2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit meson
  5. DESCRIPTION="Minimal seat management daemon and universal library"
  6. HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
  7. if [[ ${PV} == 9999 ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
  10. else
  11. KEYWORDS="~amd64"
  12. SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
  13. fi
  14. LICENSE="MIT"
  15. SLOT="0/1"
  16. IUSE="elogind systemd"
  17. REQUIRED_USE="?? ( elogind systemd )"
  18. DEPEND="
  19. elogind? ( sys-auth/elogind )
  20. systemd? ( sys-apps/systemd )
  21. "
  22. RDEPEND="${DEPEND}"
  23. BDEPEND=">=app-text/scdoc-1.9.7"
  24. src_configure() {
  25. local emesonargs=(
  26. -Dman-pages=enabled
  27. )
  28. if use elogind || use systemd; then
  29. emesonargs+=( -Dlogind=enabled )
  30. else
  31. emesonargs+=( -Dlogind=disabled )
  32. fi
  33. meson_src_configure
  34. }
  35. src_install() {
  36. meson_src_install
  37. newinitd "${FILESDIR}/seatd.initd" seatd
  38. }