logo

overlay

My own overlay for experimentations, use with caution, no support is provided

seatd-0.3.0.ebuild (869B)


  1. # Copyright 2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit meson
  5. DESCRIPTION="Minimal seat management daemon and universal library"
  6. HOMEPAGE="https://git.sr.ht/~kennylevinsen/seatd"
  7. if [[ ${PV} == 9999 ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
  10. else
  11. KEYWORDS="~amd64"
  12. SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
  13. fi
  14. LICENSE="MIT"
  15. SLOT="0/1"
  16. IUSE="examples logind"
  17. DEPEND="logind? ( || ( sys-auth/elogind sys-apps/systemd ) )"
  18. RDEPEND="${DEPEND}"
  19. BDEPEND="app-text/scdoc"
  20. src_configure() {
  21. local emesonargs=(
  22. -Dman-pages=enabled
  23. $(meson_feature examples)
  24. $(meson_feature logind)
  25. )
  26. meson_src_configure
  27. }
  28. src_install() {
  29. meson_src_install
  30. newinitd "${FILESDIR}/seatd.initd" seatd
  31. }