logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

utils-std-9999.ebuild (938B)


  1. # Copyright 2021-2024 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="Collection of commonly available Unix tools"
  6. HOMEPAGE="https://hacktivis.me/git/utils-std"
  7. EGIT_REPO_URI="https://hacktivis.me/git/utils-std.git"
  8. LICENSE="MPL-2.0"
  9. SLOT="0"
  10. IUSE="test static"
  11. RESTRICT="!test? ( test )"
  12. # atf is both needed as a library and a test framework
  13. DEPEND="test? ( dev-libs/atf )"
  14. BDEPEND="
  15. app-alternatives/yacc
  16. test? (
  17. dev-libs/atf
  18. dev-util/kyua
  19. dev-util/cram
  20. )
  21. "
  22. src_configure() {
  23. export NO_BWRAP=1
  24. use static && export CFLAGS="${CFLAGS} -static"
  25. ./configure PREFIX='/opt/lanodan'
  26. }
  27. src_install() {
  28. emake install DESTDIR="${D}"
  29. # before 50baselayout
  30. newenvd - 40lanodan <<-EOF
  31. PATH="/opt/lanodan/bin:/opt/lanodan/sbin"
  32. ROOTPATH="/opt/lanodan/bin:/opt/lanodan/sbin"
  33. MANPATH="/opt/lanodan/share/man"
  34. EOF
  35. }