logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

utils-std-9999.ebuild (813B)


  1. # Copyright 2021-2024 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="Collection of commonly available Unix tools"
  6. HOMEPAGE="https://hacktivis.me/git/utils-std"
  7. EGIT_REPO_URI="https://hacktivis.me/git/utils-std.git"
  8. LICENSE="MPL-2.0"
  9. SLOT="0"
  10. IUSE="test static"
  11. RESTRICT="!test? ( test )"
  12. BDEPEND="
  13. app-alternatives/yacc
  14. test? ( dev-util/cram )
  15. "
  16. src_configure() {
  17. export NO_BWRAP=1
  18. use static && export LDSTATIC="-static-pie"
  19. ./configure PREFIX='/opt/lanodan'
  20. }
  21. src_install() {
  22. emake install DESTDIR="${D}"
  23. # before 50baselayout
  24. newenvd - 40lanodan <<-EOF
  25. PATH="/opt/lanodan/bin:/opt/lanodan/sbin"
  26. ROOTPATH="/opt/lanodan/bin:/opt/lanodan/sbin"
  27. MANPATH="/opt/lanodan/share/man"
  28. EOF
  29. }