logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

utils-extra-9999.ebuild (617B)


  1. # Copyright 2021-2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="Collection of extra tools for Unixes"
  6. HOMEPAGE="https://hacktivis.me/git/utils-extra"
  7. EGIT_REPO_URI="https://hacktivis.me/git/utils-extra.git"
  8. LICENSE="MPL-2.0"
  9. SLOT="0"
  10. IUSE="test static"
  11. RESTRICT="!test? ( test )"
  12. BDEPEND="
  13. test? (
  14. dev-libs/atf
  15. dev-util/kyua
  16. )
  17. "
  18. src_configure() {
  19. export NO_BWRAP=1
  20. use static && export CFLAGS="${CFLAGS} -static"
  21. ./configure PREFIX='/usr'
  22. }
  23. src_install() {
  24. emake install DESTDIR="${D}"
  25. }