logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

tcb-1.2.ebuild (750B)


  1. # Copyright 2021 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DESCRIPTION="Libraries and tools implementing the tcb password shadowing scheme"
  5. HOMEPAGE="http://www.openwall.com/tcb/"
  6. SRC_URI="https://www.openwall.com/tcb/${P}.tar.gz"
  7. LICENSE="BSD"
  8. SLOT="0"
  9. KEYWORDS="~amd64"
  10. IUSE="pam"
  11. DEPEND="
  12. sys-libs/libxcrypt:=
  13. "
  14. RDEPEND="${DEPEND}"
  15. src_prepare() {
  16. sed -i 's;CC =;#&;' "${S}/Make.defs" || die "Failed un-forcing CC"
  17. if use !pam; then
  18. sed -i '/pam_tcb/d' Makefile \
  19. || die "Failed disabling pam_tcb"
  20. fi
  21. default
  22. }
  23. src_install() {
  24. einstalldocs
  25. emake install DESTDIR="${D}" \
  26. SLIBDIR=/$(get_libdir) LIBDIR=/usr/$(get_libdir) MANDIR=/usr/share/man
  27. }