logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

tcb-1.2-r1.ebuild (853B)


  1. # Copyright 2021 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DESCRIPTION="Libraries and tools implementing the tcb password shadowing scheme"
  5. HOMEPAGE="http://www.openwall.com/tcb/"
  6. SRC_URI="https://www.openwall.com/tcb/${P}.tar.gz"
  7. LICENSE="BSD"
  8. SLOT="0"
  9. KEYWORDS="~amd64"
  10. IUSE="pam static-libs"
  11. DEPEND="
  12. acct-group/chkpwd
  13. acct-group/shadow
  14. sys-libs/libxcrypt:=
  15. "
  16. RDEPEND="${DEPEND}"
  17. src_prepare() {
  18. sed -i 's;CC =;#&;' "${S}/Make.defs" || die "Failed un-forcing CC"
  19. if use !pam; then
  20. sed -i '/pam_tcb/d' Makefile \
  21. || die "Failed disabling pam_tcb"
  22. fi
  23. default
  24. }
  25. src_install() {
  26. einstalldocs
  27. emake install DESTDIR="${D}" \
  28. SLIBDIR=/$(get_libdir) LIBDIR=/usr/$(get_libdir) MANDIR=/usr/share/man
  29. use static-libs || find "${D}" -name '*.a' -delete
  30. }