logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

lanodan-utils-9999.ebuild (872B)


  1. # Copyright 2021-2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="Collection of Unix tools, comparable to coreutils"
  6. HOMEPAGE="https://hacktivis.me/git/utils"
  7. EGIT_REPO_URI="https://hacktivis.me/git/utils.git"
  8. LICENSE="MPL-2.0"
  9. SLOT="0"
  10. IUSE="suspend test"
  11. RESTRICT="!test? ( test )"
  12. BDEPEND="
  13. test? (
  14. dev-libs/atf
  15. dev-util/kyua
  16. dev-util/cram
  17. )
  18. "
  19. src_configure() {
  20. export NO_BWRAP=1
  21. ./configure PREFIX='/opt/lanodan'
  22. }
  23. src_install() {
  24. emake install DESTDIR="${D}"
  25. if use !suspend; then
  26. rm "${D}/opt/lanodan/bin/memsys" || die "Failed removing memsys"
  27. fi
  28. # before 50baselayout
  29. newenvd - 40lanodan <<-EOF
  30. PATH="/opt/lanodan/bin:/opt/lanodan/sbin"
  31. ROOTPATH="/opt/lanodan/bin:/opt/lanodan/sbin"
  32. MANPATH="/opt/lanodan/share/man"
  33. EOF
  34. }