logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://anongit.hacktivis.me/git/overlay.git/

hardenedtmpfiles-0.5.3-r1.ebuild (575B)


  1. # Copyright 2021-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="A standalone utility to process systemd-style tmpfiles.d files"
  5. HOMEPAGE="https://github.com/KenjiBrown/hardenedtmpfiles"
  6. SRC_URI="https://github.com/KenjiBrown/hardenedtmpfiles/archive/${PV}.tar.gz -> ${P}.tar.gz"
  7. KEYWORDS="~amd64"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. src_install() {
  11. emake DESTDIR="${ED}" install
  12. einstalldocs
  13. for i in opentmpfiles-dev opentmpfiles-setup; do
  14. newconfd openrc/${i}.confd ${i}
  15. newinitd openrc/${i}.initd ${i}
  16. done
  17. }