logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

bubblewrap-0.4.0.ebuild (1107B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit bash-completion-r1 linux-info
  5. DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
  6. HOMEPAGE="https://github.com/containers/bubblewrap"
  7. SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
  8. LICENSE="LGPL-2+"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
  11. IUSE="selinux +suid"
  12. RDEPEND="
  13. sys-libs/libseccomp
  14. sys-libs/libcap
  15. selinux? ( >=sys-libs/libselinux-2.1.9 )
  16. "
  17. DEPEND="${RDEPEND}
  18. app-text/docbook-xml-dtd:4.3
  19. app-text/docbook-xsl-stylesheets
  20. dev-libs/libxslt
  21. virtual/pkgconfig
  22. "
  23. # tests require root priviledge
  24. RESTRICT="test"
  25. PATCHES=( "${FILESDIR}/${P}_realpath-workaround.patch" )
  26. pkg_setup() {
  27. if [[ ${MERGE_TYPE} != buildonly ]]; then
  28. CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
  29. linux-info_pkg_setup
  30. fi
  31. }
  32. src_configure() {
  33. econf \
  34. $(use_enable selinux) \
  35. "--enable-man" \
  36. "--with-bash-completion-dir=$(get_bashcompdir)" \
  37. "--with-priv-mode=$(usex suid setuid none)"
  38. }