logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

stig-0.10.1a.ebuild (871B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{5,6,7} )
  5. inherit distutils-r1
  6. DESCRIPTION="TUI and CLI for the BitTorrent client Transmission"
  7. HOMEPAGE="https://github.com/rndusr/stig"
  8. SRC_URI="https://github.com/rndusr/stig/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. IUSE="geoip test"
  13. RDEPEND="
  14. >=dev-python/urwid-2.0
  15. >=dev-python/urwidtrees-1.0.2
  16. dev-python/aiohttp
  17. dev-python/async_timeout
  18. dev-python/pyxdg
  19. dev-python/blinker
  20. dev-python/natsort
  21. geoip? ( dev-python/maxminddb )
  22. dev-python/setproctitle
  23. "
  24. DEPEND="
  25. ${RDEPEND}
  26. test? ( dev-python/asynctest )
  27. "
  28. src_prepare() {
  29. # Taken from Void Linux
  30. sed -i 's/urwidtrees>=1.0.3dev0/urwidtrees>=1.0.2/' setup.py || die
  31. distutils-r1_src_prepare
  32. }