logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gnunet-0.11.0_pre66.ebuild (1581B)


  1. # Copyright 1999-2019 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit user
  5. MY_PV="0.11.0pre66"
  6. DESCRIPTION="GNUnet is a framework for secure peer-to-peer networking."
  7. HOMEPAGE="https://gnunet.org/"
  8. LICENSE="GPL-3"
  9. SRC_URI="mirror://gnu/${PN}/${PN}-${MY_PV}.tar.gz"
  10. KEYWORDS="~amd64"
  11. SLOT="0"
  12. IUSE="experimental http mysql postgres nls +sqlite X +libextractor"
  13. REQUIRED_USE="|| ( mysql postgres sqlite )"
  14. S="${WORKDIR}/${PN}-${MY_PV}"
  15. DEPEND="
  16. >=net-misc/curl-7.21.0
  17. dev-libs/libgcrypt
  18. >=dev-libs/libunistring-0.9.2
  19. sys-libs/ncurses
  20. sys-libs/zlib
  21. libextractor? ( >=media-libs/libextractor-0.6.1 )
  22. http? ( >=net-libs/libmicrohttpd-0.9.18 )
  23. mysql? ( >=virtual/mysql-5.1 )
  24. postgres? ( dev-db/postgresql )
  25. nls? ( sys-devel/gettext )
  26. sqlite? ( >=dev-db/sqlite-3.0 )
  27. X? (
  28. x11-libs/libXt
  29. x11-libs/libXext
  30. x11-libs/libX11
  31. x11-libs/libXrandr
  32. )
  33. "
  34. pkg_setup() {
  35. enewgroup gnunetdns
  36. enewuser gnunet
  37. }
  38. src_configure() {
  39. econf \
  40. --docdir="${EPREFIX}/usr/share/doc/${PF}" \
  41. $(use_enable nls) \
  42. $(use_enable experimental) \
  43. $(use_with http microhttpd) \
  44. $(use_with mysql) \
  45. $(use_with postgres postgresql) \
  46. $(use_with sqlite) \
  47. $(use_with X x)
  48. }
  49. src_install() {
  50. emake -j1 DESTDIR="${D}" install
  51. newinitd "${FILESDIR}"/${PN}-9999.initd gnunet
  52. keepdir /var/{lib,log}/gnunet
  53. fowners gnunet:gnunet /var/lib/gnunet /var/log/gnunet
  54. }
  55. pkg_postinst() {
  56. einfo
  57. einfo "To configure"
  58. einfo " 1) Add user(s) to the gnunet group"
  59. einfo " 2) Edit the server config file '/etc/gnunet.conf'"
  60. einfo
  61. }