logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

suck-4.3.4.ebuild (1284B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit autotools
  5. DESCRIPTION="Grab news from a remote NNTP server and feed them to another"
  6. HOMEPAGE="https://lazarus-pkgs.github.io/lazarus-pkgs/suck.html"
  7. SRC_URI="https://github.com/lazarus-pkgs/suck/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="public-domain"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE="perl ssl"
  12. RDEPEND="
  13. sys-libs/gdbm:=
  14. ssl? ( dev-libs/openssl:0= )
  15. "
  16. DEPEND="${RDEPEND}
  17. sys-libs/db
  18. perl? ( dev-lang/perl )
  19. "
  20. src_prepare() {
  21. default
  22. # Fix paths to the locations in Gentoo
  23. sed -i \
  24. -e 's:/usr/bin/rnews:/usr/$(get_libdir)/news/bin/rnews:' \
  25. -e 's:/var/lib/news/history:/var/spool/news/db/history:' \
  26. suck_config.h || die "path adaption sed failed"
  27. eautoreconf
  28. }
  29. src_configure() {
  30. use ssl || sed -i -e 's/^SSL_/#SSL_/' Makefile.in || die "ssl sed failed"
  31. use perl || sed -i -e 's/^PERL_/#PERL_/' Makefile.in || die "perl sed failed"
  32. econf --without-inn-lib --without-inn-include
  33. }
  34. src_compile() {
  35. emake phrases.h
  36. emake all lpost
  37. }
  38. src_install() {
  39. dobin lmove lpost rpost suck testhost
  40. doman man/*
  41. dodoc CHANGELOG CONTENTS README*
  42. docinto java
  43. dodoc java/*
  44. docinto perl
  45. dodoc perl/*
  46. docinto sample
  47. dodoc sample/*
  48. }