logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

newsboat-2.13-r1.ebuild (1188B)


  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit toolchain-funcs
  5. DESCRIPTION="An RSS/Atom feed reader for text terminals"
  6. HOMEPAGE="https://newsboat.org/ https://github.com/newsboat/newsboat"
  7. KEYWORDS="~amd64 ~x86"
  8. SRC_URI="https://newsboat.org/releases/${PV}/${P}.tar.xz"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. IUSE=""
  12. RDEPEND="
  13. >=dev-db/sqlite-3.5:3
  14. >=dev-libs/stfl-0.21
  15. >=net-misc/curl-7.18.0
  16. >=dev-libs/json-c-0.11:=
  17. dev-libs/libxml2
  18. sys-libs/ncurses:0=[unicode(+)]
  19. "
  20. DEPEND="${RDEPEND}
  21. app-text/asciidoc
  22. virtual/pkgconfig
  23. sys-devel/gettext
  24. "
  25. PATCHES=(
  26. "${FILESDIR}"/${PN}-2.11-flags.patch
  27. "${FILESDIR}"/${PN}-2.13-json-c-0.14.0.patch
  28. )
  29. src_configure() {
  30. ./config.sh || die
  31. }
  32. src_compile() {
  33. emake prefix="/usr" CXX="$(tc-getCXX)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
  34. }
  35. src_test() {
  36. # tests require UTF-8 locale
  37. emake CXX="$(tc-getCXX)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" test
  38. # Tests fail if in ${S} rather than in ${S}/test
  39. cd "${S}"/test || die
  40. ./test || die
  41. }
  42. src_install() {
  43. emake DESTDIR="${D}" prefix="/usr" docdir="/usr/share/doc/${PF}" install
  44. dodoc CHANGELOG.md README.md TODO
  45. }