logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

streamlink-1.5.0.ebuild (1436B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{6,7,8} )
  5. PYTHON_REQ_USE='xml(+),threads(+)'
  6. DISTUTILS_SINGLE_IMPL=1
  7. DISTUTILS_USE_SETUPTOOLS=rdepend
  8. inherit distutils-r1
  9. DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
  10. HOMEPAGE="https://streamlink.github.io/"
  11. SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
  12. KEYWORDS="~amd64 ~x86"
  13. LICENSE="BSD-2 Apache-2.0"
  14. SLOT="0"
  15. IUSE="doc"
  16. DEPEND="
  17. $(python_gen_cond_dep '
  18. >dev-python/requests-2.21.0[${PYTHON_MULTI_USEDEP}]
  19. dev-python/isodate[${PYTHON_MULTI_USEDEP}]
  20. dev-python/websocket-client[${PYTHON_MULTI_USEDEP}]
  21. dev-python/pycountry[${PYTHON_MULTI_USEDEP}]
  22. >=dev-python/pycryptodome-3.4.3[${PYTHON_MULTI_USEDEP}]
  23. ')
  24. "
  25. RDEPEND="${DEPEND}
  26. media-video/rtmpdump
  27. media-video/ffmpeg
  28. "
  29. BDEPEND="
  30. $(python_gen_cond_dep '
  31. doc? (
  32. dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
  33. dev-python/docutils[${PYTHON_MULTI_USEDEP}]
  34. dev-python/recommonmark[${PYTHON_MULTI_USEDEP}]
  35. )
  36. ')"
  37. python_configure_all() {
  38. # Avoid iso-639, iso3166 dependencies since we use pycountry.
  39. export STREAMLINK_USE_PYCOUNTRY=1
  40. }
  41. python_compile_all() {
  42. use doc && emake -C docs html man
  43. }
  44. python_install_all() {
  45. if use doc; then
  46. local HTML_DOCS=( docs/_build/html/. )
  47. doman docs/_build/man/*
  48. fi
  49. distutils-r1_python_install_all
  50. }