streamlink-1.5.0.ebuild (1436B)
- # Copyright 1999-2020 Gentoo Authors
- # Distributed under the terms of the GNU General Public License v2
- EAPI=7
- PYTHON_COMPAT=( python3_{6,7,8} )
- PYTHON_REQ_USE='xml(+),threads(+)'
- DISTUTILS_SINGLE_IMPL=1
- DISTUTILS_USE_SETUPTOOLS=rdepend
- inherit distutils-r1
- DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
- HOMEPAGE="https://streamlink.github.io/"
- SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- LICENSE="BSD-2 Apache-2.0"
- SLOT="0"
- IUSE="doc"
- DEPEND="
- $(python_gen_cond_dep '
- >dev-python/requests-2.21.0[${PYTHON_MULTI_USEDEP}]
- dev-python/isodate[${PYTHON_MULTI_USEDEP}]
- dev-python/websocket-client[${PYTHON_MULTI_USEDEP}]
- dev-python/pycountry[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pycryptodome-3.4.3[${PYTHON_MULTI_USEDEP}]
- ')
- "
- RDEPEND="${DEPEND}
- media-video/rtmpdump
- media-video/ffmpeg
- "
- BDEPEND="
- $(python_gen_cond_dep '
- doc? (
- dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
- dev-python/docutils[${PYTHON_MULTI_USEDEP}]
- dev-python/recommonmark[${PYTHON_MULTI_USEDEP}]
- )
- ')"
- python_configure_all() {
- # Avoid iso-639, iso3166 dependencies since we use pycountry.
- export STREAMLINK_USE_PYCOUNTRY=1
- }
- python_compile_all() {
- use doc && emake -C docs html man
- }
- python_install_all() {
- if use doc; then
- local HTML_DOCS=( docs/_build/html/. )
- doman docs/_build/man/*
- fi
- distutils-r1_python_install_all
- }