logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

neatvnc-9999.ebuild (701B)


  1. # Copyright 2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit meson git-r3
  5. DESCRIPTION="liberally licensed VNC server library that's intended to be fast and neat"
  6. HOMEPAGE="https://github.com/any1/neatvnc"
  7. EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
  8. LICENSE="ISC"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="gnutls jpeg"
  12. DEPEND="
  13. x11-libs/pixman:=
  14. dev-libs/libuv:=
  15. gnutls? ( net-libs/gnutls:= )
  16. jpeg? ( media-libs/libjpeg-turbo:= )
  17. "
  18. RDEPEND="
  19. ${DEPEND}
  20. x11-libs/libdrm
  21. "
  22. src_configure() {
  23. local emesonargs=(
  24. $(meson_feature jpeg tight-encoding)
  25. $(meson_feature gnutls tls)
  26. )
  27. meson_src_configure
  28. }