logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

geomyidae-0.31.1.ebuild (840B)


  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit user
  5. DESCRIPTION="A small C-based gopherd."
  6. HOMEPAGE="gopher://bitreich.org/1/scm/geomyidae http://git.r-36.net/geomyidae/"
  7. SRC_URI="http://git.r-36.net/geomyidae/snapshot/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="xinetd"
  12. DEPEND=""
  13. RDEPEND="xinetd? ( virtual/inetd )"
  14. pkg_setup() {
  15. enewgroup ${P}
  16. enewuser ${P} -1 -1 "/var/gopher" ${P}
  17. }
  18. src_install() {
  19. default
  20. if use xinetd
  21. then
  22. insinto /etc/xinetd.d
  23. newins "${FILESDIR}/geomyidae.xinetd" ${PN}
  24. else
  25. newinitd "${FILESDIR}/geomyidae.initd" ${PN}
  26. elog "By default this init is using port 7000 and obfuscates to port 70 to avoid running as root."
  27. elog "This needs you to add a iptables rule to redirect 7000 to 70."
  28. fi
  29. }