logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

fbxosctrl-2.4.4.ebuild (781B)


  1. # Copyright 2018-2021 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{7,8,9} )
  5. inherit python-single-r1
  6. DESCRIPTION="Shell tool to control some Freebox OS stuff: wifi, reboot..."
  7. HOMEPAGE="https://github.com/skimpax/fbxosctrl"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~x86"
  11. SRC_URI="https://github.com/skimpax/fbxosctrl/archive/${PV}.tar.gz -> ${P}.tar.gz"
  12. DEPEND="
  13. ${PYTHON_DEPS}
  14. dev-python/requests[${PYTHON_USEDEP}]
  15. "
  16. DOCS=("${DISTDIR}/fbxosctrl-lisezmoi.md")
  17. src_install() {
  18. default
  19. python_doexe fbxosctrl.py
  20. }
  21. pkg_install() {
  22. emessage "Pour la mise en place, voir: https://raw.githubusercontent.com/wiki/skimpax/fbxosctrl/Mise-en-oeuvre-de-fbxosctrl.md"
  23. }