logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

fbxosctrl-2.3.2.ebuild (745B)


  1. # Copyright 2018 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{4,5,6} )
  5. inherit python-single-r1
  6. DESCRIPTION="Shell tool to control some Freebox OS stuff: wifi, reboot..."
  7. HOMEPAGE="https://github.com/skimpax/fbxosctrl"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~x86"
  11. SRC_URI="
  12. https://github.com/skimpax/fbxosctrl/archive/${PV}.tar.gz -> ${P}.tar.gz
  13. https://raw.githubusercontent.com/wiki/skimpax/fbxosctrl/Mise-en-oeuvre-de-fbxosctrl.md -> fbxosctrl-lisezmoi.md
  14. "
  15. DEPEND="
  16. ${PYTHON_DEPS}
  17. dev-python/requests[${PYTHON_USEDEP}]
  18. "
  19. DOCS=("${DISTDIR}/fbxosctrl-lisezmoi.md")
  20. src_install() {
  21. default
  22. python_doexe fbxosctrl.py
  23. }