logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

public-inbox-1.0.0.ebuild (756B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. HOMEPAGE="https://public-inbox.org/"
  5. SRC_URI="https://public-inbox.org/releases/${P}.tar.gz"
  6. SLOT="0"
  7. KEYWORDS="~amd64"
  8. IUSE="+xapian gzip nntp inbox_watch daemon"
  9. DEPEND="
  10. dev-vcs/git
  11. dev-lang/perl
  12. dev-db/sqlite
  13. dev-perl/Time-ParseDate
  14. dev-perl/Email-MIME
  15. dev-perl/Email-MIME-ContentType
  16. dev-perl/Plack
  17. dev-perl/URI
  18. xapian? (
  19. dev-perl/Search-Xapian
  20. )
  21. gzip? (
  22. dev-perl/PerlIO-gzip
  23. dev-perl/DBI
  24. dev-perl/DBD-SQLite
  25. )
  26. nntp? (
  27. dev-perl/DBD-SQLite
  28. )
  29. inbox_watch? (
  30. dev-perl/Filesys-Notify-Simple
  31. )
  32. daemon? (
  33. dev-perl/Inline-C
  34. )
  35. "
  36. src_prepare() {
  37. default
  38. perl Makefile.PL || die
  39. }