logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

wpewebkit-2.28.1.ebuild (2909B)


  1. # Copyright 2019-2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CMAKE_MAKEFILE_GENERATOR="ninja"
  5. PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
  6. USE_RUBY="ruby24 ruby25 ruby26"
  7. inherit cmake python-any-r1 ruby-single
  8. DESCRIPTION="WebKit port optimized for embedded devices"
  9. HOMEPAGE="https://wpewebkit.org/"
  10. LICENSE="LGPL-2+ BSD"
  11. SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
  12. SLOT="1.0" # WPE_API_VERSION
  13. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux "
  14. IUSE="accessibility doc examples experimental jpeg2k qt +gstreamer sandbox +webdriver +webcrypto"
  15. RDEPEND="
  16. >=x11-libs/cairo-1.14.0:=
  17. >=media-libs/fontconfig-2.8.0:=
  18. >=media-libs/freetype-2.4.2:=
  19. >=dev-libs/glib-2.44.0:=
  20. >=media-libs/harfbuzz-0.9.18:=
  21. dev-libs/icu
  22. virtual/jpeg:=
  23. >=media-libs/libepoxy-1.4.0:=
  24. >=dev-libs/libgcrypt-1.6.0:=
  25. >=net-libs/libsoup-2.54.0:=
  26. >=dev-libs/libxml2-2.8.0:=
  27. media-libs/libpng:=
  28. dev-db/sqlite:=
  29. media-libs/libwebp:=
  30. gui-libs/libwpe:=
  31. sys-libs/zlib:=
  32. >=dev-libs/libxslt-1.1.7
  33. >=media-libs/woff2-1.0.2
  34. jpeg2k? ( >=media-libs/openjpeg-2.2.0:2= )
  35. webcrypto? (
  36. dev-libs/libtasn1:=
  37. >=dev-libs/libgcrypt-1.7.0:=
  38. )
  39. qt? (
  40. dev-qt/qtcore:5=
  41. dev-qt/qtquickcontrols:5=
  42. dev-qt/qtgui:5=
  43. dev-qt/qttest:5=
  44. >=gui-libs/wpebackend-fdo-1.3.0:=
  45. )
  46. gstreamer? (
  47. >=media-libs/gstreamer-1.14:1.0
  48. >=media-libs/gst-plugins-base-1.14:1.0[egl]
  49. >=media-plugins/gst-plugins-opus-1.14.4-r1:1.0
  50. >=media-libs/gst-plugins-bad-1.14:1.0
  51. )
  52. accessibility? (
  53. >=dev-libs/atk-2.16.0:=
  54. app-accessibility/at-spi2-atk:=
  55. )
  56. sandbox? ( sys-apps/bubblewrap )
  57. "
  58. DEPEND="
  59. ${RDEPEND}
  60. ${PYTHON_DEPS}
  61. ${RUBY_DEPS}
  62. >=dev-lang/perl-5.10
  63. virtual/perl-JSON-PP
  64. doc? ( >=dev-util/gtk-doc-1.10 )
  65. "
  66. src_configure() {
  67. # Ruby situation is a bit complicated. See bug 513888
  68. local rubyimpl
  69. local ruby_interpreter=""
  70. for rubyimpl in ${USE_RUBY}; do
  71. if has_version "virtual/rubygems[ruby_targets_${rubyimpl}]"; then
  72. ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ${rubyimpl})"
  73. fi
  74. done
  75. # This will rarely occur. Only a couple of corner cases could lead us to
  76. # that failure. See bug 513888
  77. [[ -z $ruby_interpreter ]] && die "No suitable ruby interpreter found"
  78. local mycmakeargs=(
  79. "-DPORT=WPE"
  80. -DENABLE_ACCESSIBILITY=$(usex accessibility)
  81. -DENABLE_BUBBLEWRAP_SANDBOX=$(usex sandbox)
  82. -DUSE_WOFF2=ON
  83. -DSHOULD_INSTALL_JS_SHELL=ON
  84. -DENABLE_ENCRYPTED_MEDIA=OFF
  85. -DENABLE_EXPERIMENTAL_FEATURES=$(usex experimental)
  86. -DENABLE_GTKDOC=$(usex doc)
  87. -DUSE_OPENJPEG=$(usex jpeg2k)
  88. -DENABLE_WPE_QT_API=$(usex qt)
  89. -DENABLE_MINIBROWSER=$(usex examples)
  90. -DENABLE_VIDEO=$(usex gstreamer)
  91. -DENABLE_WEB_AUDIO=$(usex gstreamer)
  92. -DENABLE_WEBDRIVER=$(usex webdriver)
  93. -DENABLE_WEB_CRYPTO=$(usex webcrypto)
  94. -DENABLE_XSLT=ON
  95. ${ruby_interpreter}
  96. )
  97. cmake_src_configure
  98. }