logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

webkit-gtk-2.46.2-r410.ebuild (7354B)


  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CMAKE_MAKEFILE_GENERATOR="ninja"
  5. PYTHON_REQ_USE="xml(+)"
  6. PYTHON_COMPAT=( python3_{10..12} )
  7. USE_RUBY="ruby30 ruby31 ruby32 ruby33"
  8. inherit check-reqs flag-o-matic gnome2 optfeature python-any-r1 ruby-single toolchain-funcs cmake
  9. MY_P="webkitgtk-${PV}"
  10. DESCRIPTION="Open source web browser engine"
  11. HOMEPAGE="https://www.webkitgtk.org"
  12. SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
  13. # Apache-2.0 for fast_float, ANGLE (also pdfjs but disabled)
  14. # See https://bugs.webkit.org/show_bug.cgi?id=254717
  15. LICENSE="LGPL-2+ BSD Apache-2.0"
  16. SLOT="4.1/0" # soname version of libwebkit2gtk-4.1
  17. KEYWORDS="~amd64 ~arm64"
  18. IUSE="aqua +avif dbus doc examples gamepad keyring +gstreamer +introspection pdf jpegxl +jumbo-build lcms +seccomp spell sysprof systemd wayland webrtc +X"
  19. REQUIRED_USE="
  20. doc? ( introspection )
  21. webrtc? ( gstreamer )
  22. || ( aqua wayland X )
  23. "
  24. # Tests are currently unsupported in release tarballs
  25. # https://bugs.webkit.org/show_bug.cgi?id=215986
  26. # Tools/Scripts/run-gtk-tests: Command not found
  27. RESTRICT="test"
  28. # Dependencies found at Source/cmake/OptionsGTK.cmake
  29. RDEPEND="
  30. >=x11-libs/cairo-1.16.0:=[X?]
  31. >=media-libs/fontconfig-2.13.0:1.0
  32. >=media-libs/freetype-2.9.0:2
  33. >=dev-libs/libgcrypt-1.7.0:0=
  34. >=x11-libs/gtk+-3.22.0:3[aqua?,introspection?,wayland?,X?]
  35. >=media-libs/harfbuzz-1.4.2:=[icu(+)]
  36. >=dev-libs/icu-61.2:=
  37. media-libs/libjpeg-turbo:0=
  38. >=media-libs/libepoxy-1.4.0
  39. >=net-libs/libsoup-2.99.9:3.0[introspection?]
  40. >=dev-libs/libxml2-2.8.0:2
  41. >=media-libs/libpng-1.4:0=
  42. dev-db/sqlite:3=
  43. sys-libs/zlib:0
  44. >=dev-libs/atk-2.16.0[introspection?]
  45. media-libs/libwebp:=
  46. >=dev-libs/glib-2.70.0:2
  47. >=dev-libs/libxslt-1.1.7
  48. media-libs/woff2
  49. keyring? ( app-crypt/libsecret )
  50. introspection? ( >=dev-libs/gobject-introspection-1.59.1:= )
  51. dev-libs/libtasn1:=
  52. spell? ( >=app-text/enchant-0.22:2 )
  53. gstreamer? (
  54. >=media-libs/gstreamer-1.20:1.0
  55. >=media-libs/gst-plugins-base-1.20:1.0[egl,X?]
  56. media-libs/gst-plugins-base:1.0[opengl]
  57. >=media-plugins/gst-plugins-opus-1.20:1.0
  58. >=media-libs/gst-plugins-bad-1.20:1.0[X?]
  59. )
  60. webrtc? (
  61. media-plugins/gst-plugins-webrtc:1.0
  62. >=dev-libs/openssl-3:=
  63. )
  64. X? (
  65. x11-libs/libX11
  66. x11-libs/libXcomposite
  67. x11-libs/libXdamage
  68. x11-libs/libXrender
  69. x11-libs/libXt
  70. )
  71. dev-libs/hyphen
  72. jpegxl? ( media-libs/libjxl )
  73. avif? ( >=media-libs/libavif-0.9.0:= )
  74. lcms? ( media-libs/lcms:2 )
  75. media-libs/mesa
  76. media-libs/libglvnd
  77. wayland? (
  78. >=dev-libs/wayland-1.15
  79. >=dev-libs/wayland-protocols-1.15
  80. )
  81. seccomp? (
  82. >=sys-apps/bubblewrap-0.3.1
  83. sys-libs/libseccomp
  84. sys-apps/xdg-dbus-proxy
  85. )
  86. sysprof? ( dev-util/sysprof-capture:4 )
  87. systemd? ( sys-apps/systemd:= )
  88. gamepad? ( >=dev-libs/libmanette-0.2.4 )
  89. "
  90. DEPEND="${RDEPEND}"
  91. # Need real bison, not yacc
  92. BDEPEND="
  93. ${PYTHON_DEPS}
  94. ${RUBY_DEPS}
  95. dev-util/glib-utils
  96. >=dev-util/gperf-3.0.1
  97. dev-util/unifdef
  98. >=sys-devel/bison-2.4.3
  99. || ( >=sys-devel/gcc-7.3 >=sys-devel/clang-5 )
  100. sys-devel/gettext
  101. virtual/pkgconfig
  102. >=dev-lang/perl-5.10
  103. virtual/perl-Data-Dumper
  104. virtual/perl-Carp
  105. virtual/perl-JSON-PP
  106. dbus? ( dev-util/gdbus-codegen )
  107. doc? ( dev-util/gi-docgen )
  108. "
  109. S="${WORKDIR}/${MY_P}"
  110. CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
  111. pkg_pretend() {
  112. if [[ ${MERGE_TYPE} != "binary" ]] ; then
  113. if is-flagq "-g*" && ! is-flagq "-g*0" ; then
  114. einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
  115. check-reqs_pkg_pretend
  116. fi
  117. if ! test-flag-CXX -std=c++17 ; then
  118. die "You need at least GCC 7.3.x or Clang >= 5 for C++17-specific compiler flags"
  119. fi
  120. fi
  121. }
  122. pkg_setup() {
  123. if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
  124. check-reqs_pkg_setup
  125. fi
  126. python-any-r1_pkg_setup
  127. }
  128. src_prepare() {
  129. cmake_src_prepare
  130. gnome2_src_prepare
  131. }
  132. src_configure() {
  133. # Respect CC, otherwise fails on prefix #395875
  134. tc-export CC
  135. # WebkitGTK doesn't likes -D_FORTIFY_SOURCE=2
  136. #strip-flags
  137. #filter-flags "-D_FORTIFY_SOURCE=*"
  138. # https://bugs.webkit.org/show_bug.cgi?id=278883
  139. filter-flags '-ftrapv'
  140. # It does not compile on alpha without this in LDFLAGS
  141. # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
  142. use alpha && append-ldflags "-Wl,--no-relax"
  143. # Sigbuses on SPARC with mcpu and co., bug #???
  144. use sparc && filter-flags "-mvis"
  145. # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
  146. use ppc64 && append-flags "-mminimal-toc"
  147. # Try to use less memory, bug #469942 (see Fedora .spec for reference)
  148. append-ldflags $(test-flags-CCLD "-Wl,--no-keep-memory")
  149. # Ruby situation is a bit complicated. See bug 513888
  150. local rubyimpl
  151. local ruby_interpreter=""
  152. local RUBY
  153. for rubyimpl in ${USE_RUBY}; do
  154. if has_version -b "virtual/rubygems[ruby_targets_${rubyimpl}(-)]"; then
  155. RUBY="$(type -P ${rubyimpl})"
  156. ruby_interpreter="-DRUBY_EXECUTABLE=${RUBY}"
  157. fi
  158. done
  159. # This will rarely occur. Only a couple of corner cases could lead us to
  160. # that failure. See bug 513888
  161. [[ -z ${ruby_interpreter} ]] && die "No suitable ruby interpreter found"
  162. # JavaScriptCore/Scripts/postprocess-asm invokes another Ruby script directly
  163. # so it doesn't respect RUBY_EXECUTABLE, bug #771744.
  164. sed -i -e "s:#!/usr/bin/env ruby:#!${RUBY}:" $(grep -rl "/usr/bin/env ruby" Source/JavaScriptCore || die) || die
  165. # TODO: Check Web Audio support
  166. # should somehow let user select between them?
  167. local mycmakeargs=(
  168. ${ruby_interpreter}
  169. # If bubblewrap[suid] then portage makes it go-r and cmake find_program fails with that
  170. -DBWRAP_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/bwrap
  171. -DDBUS_PROXY_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/xdg-dbus-proxy
  172. -DPORT=GTK
  173. # Source/cmake/WebKitFeatures.cmake
  174. -DENABLE_API_TESTS=OFF
  175. -DENABLE_BUBBLEWRAP_SANDBOX=$(usex seccomp)
  176. -DENABLE_GAMEPAD=$(usex gamepad)
  177. -DENABLE_GEOLOCATION=$(usex dbus) # Runtime optional (talks over dbus service)
  178. -DENABLE_MINIBROWSER=$(usex examples)
  179. -DENABLE_PDFJS=$(usex pdf)
  180. -DSHOULD_INSTALL_JS_SHELL=$(usex examples)
  181. -DENABLE_SPELLCHECK=$(usex spell)
  182. -DENABLE_UNIFIED_BUILDS=$(usex jumbo-build)
  183. -DENABLE_VIDEO=$(usex gstreamer)
  184. -DENABLE_WEBGL=ON
  185. -DENABLE_WEB_AUDIO=$(usex gstreamer)
  186. -DENABLE_WEBDRIVER=OFF
  187. # Source/cmake/OptionsGTK.cmake
  188. -DUSE_LIBBACKTRACE=OFF
  189. -DENABLE_DOCUMENTATION=$(usex doc)
  190. -DENABLE_INTROSPECTION=$(usex introspection)
  191. -DENABLE_JOURNALD_LOG=$(usex systemd)
  192. -DENABLE_QUARTZ_TARGET=$(usex aqua)
  193. -DENABLE_WAYLAND_TARGET=$(usex wayland)
  194. -DENABLE_WEB_RTC=$(usex webrtc)
  195. -DENABLE_MEDIA_STREAM=$(usex webrtc)
  196. -DENABLE_X11_TARGET=$(usex X)
  197. -DUSE_GBM=ON
  198. #-DUSE_ANGLE_WEBGL=OFF
  199. -DUSE_AVIF=$(usex avif)
  200. -DUSE_GTK4=OFF
  201. -DUSE_JPEGXL=$(usex jpegxl)
  202. -DUSE_LCMS=$(usex lcms)
  203. -DUSE_LIBHYPHEN=ON
  204. -DUSE_LIBSECRET=$(usex keyring)
  205. -DUSE_SOUP2=OFF
  206. -DUSE_WOFF2=ON
  207. -DUSE_SYSTEM_SYSPROF_CAPTURE=$(usex sysprof)
  208. )
  209. # https://bugs.gentoo.org/761238
  210. append-cppflags -DNDEBUG
  211. WK_USE_CCACHE=NO cmake_src_configure
  212. }
  213. pkg_postinst() {
  214. use dbus && optfeature "geolocation service (used at runtime if available)" "app-misc/geoclue"
  215. optfeature "Common Multimedia codecs" "media-plugins/gst-plugins-meta"
  216. optfeature "(MPEG-)DASH support" "media-plugins/gst-plugins-dash"
  217. optfeature "HTTP-Live-Streaming support" "media-plugins/gst-plugins-hls"
  218. }