logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

webkit-gtk-2.46.1.ebuild (7301B)


  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CMAKE_MAKEFILE_GENERATOR="ninja"
  5. PYTHON_REQ_USE="xml(+)"
  6. PYTHON_COMPAT=( python3_{10..12} )
  7. USE_RUBY="ruby30 ruby31 ruby32 ruby33"
  8. inherit check-reqs flag-o-matic gnome2 optfeature python-any-r1 ruby-single toolchain-funcs cmake
  9. MY_P="webkitgtk-${PV}"
  10. DESCRIPTION="Open source web browser engine"
  11. HOMEPAGE="https://www.webkitgtk.org"
  12. SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
  13. # Apache-2.0 for fast_float, ANGLE (also pdfjs but disabled)
  14. # See https://bugs.webkit.org/show_bug.cgi?id=254717
  15. LICENSE="LGPL-2+ BSD Apache-2.0"
  16. SLOT="4/37" # soname version of libwebkit2gtk-4.0
  17. KEYWORDS="~amd64 ~arm64"
  18. IUSE="aqua +avif dbus doc examples gamepad keyring +gstreamer +introspection pdf jpegxl +jumbo-build lcms +seccomp spell sysprof systemd wayland webrtc +X"
  19. REQUIRED_USE="
  20. doc? ( introspection )
  21. webrtc? ( gstreamer )
  22. || ( aqua wayland X )
  23. "
  24. # Tests are currently unsupported in release tarballs
  25. # https://bugs.webkit.org/show_bug.cgi?id=215986
  26. RESTRICT="test"
  27. # Dependencies found at Source/cmake/OptionsGTK.cmake
  28. RDEPEND="
  29. >=x11-libs/cairo-1.16.0:=[X?]
  30. >=media-libs/fontconfig-2.13.0:1.0
  31. >=media-libs/freetype-2.9.0:2
  32. >=dev-libs/libgcrypt-1.7.0:0=
  33. >=x11-libs/gtk+-3.22.0:3[aqua?,introspection?,wayland?,X?]
  34. >=media-libs/harfbuzz-1.4.2:=[icu(+)]
  35. >=dev-libs/icu-61.2:=
  36. media-libs/libjpeg-turbo:0=
  37. >=media-libs/libepoxy-1.4.0
  38. >=net-libs/libsoup-2.54:2.4[introspection?]
  39. >=dev-libs/libxml2-2.8.0:2
  40. >=media-libs/libpng-1.4:0=
  41. dev-db/sqlite:3=
  42. sys-libs/zlib:0
  43. >=dev-libs/atk-2.16.0[introspection?]
  44. media-libs/libwebp:=
  45. >=dev-libs/glib-2.70.0:2
  46. >=dev-libs/libxslt-1.1.7
  47. media-libs/woff2
  48. keyring? ( app-crypt/libsecret )
  49. introspection? ( >=dev-libs/gobject-introspection-1.59.1:= )
  50. dev-libs/libtasn1:=
  51. spell? ( >=app-text/enchant-0.22:2 )
  52. gstreamer? (
  53. >=media-libs/gstreamer-1.20:1.0
  54. >=media-libs/gst-plugins-base-1.20:1.0[egl,X?]
  55. media-libs/gst-plugins-base:1.0[opengl]
  56. >=media-plugins/gst-plugins-opus-1.20:1.0
  57. >=media-libs/gst-plugins-bad-1.20:1.0[X?]
  58. )
  59. webrtc? (
  60. media-plugins/gst-plugins-webrtc:1.0
  61. >=dev-libs/openssl-3:=
  62. )
  63. X? (
  64. x11-libs/libX11
  65. x11-libs/libXcomposite
  66. x11-libs/libXdamage
  67. x11-libs/libXrender
  68. x11-libs/libXt
  69. )
  70. dev-libs/hyphen
  71. jpegxl? ( media-libs/libjxl )
  72. avif? ( >=media-libs/libavif-0.9.0:= )
  73. lcms? ( media-libs/lcms:2 )
  74. media-libs/mesa
  75. media-libs/libglvnd
  76. wayland? (
  77. >=dev-libs/wayland-1.15
  78. >=dev-libs/wayland-protocols-1.15
  79. )
  80. seccomp? (
  81. >=sys-apps/bubblewrap-0.3.1
  82. sys-libs/libseccomp
  83. sys-apps/xdg-dbus-proxy
  84. )
  85. sysprof? ( dev-util/sysprof-capture:4 )
  86. systemd? ( sys-apps/systemd:= )
  87. gamepad? ( >=dev-libs/libmanette-0.2.4 )
  88. "
  89. DEPEND="${RDEPEND}"
  90. # Need real bison, not yacc
  91. BDEPEND="
  92. ${PYTHON_DEPS}
  93. ${RUBY_DEPS}
  94. dev-util/glib-utils
  95. >=dev-util/gperf-3.0.1
  96. dev-util/unifdef
  97. >=sys-devel/bison-2.4.3
  98. || ( >=sys-devel/gcc-7.3 >=sys-devel/clang-5 )
  99. sys-devel/gettext
  100. virtual/pkgconfig
  101. >=dev-lang/perl-5.10
  102. virtual/perl-Data-Dumper
  103. virtual/perl-Carp
  104. virtual/perl-JSON-PP
  105. dbus? ( dev-util/gdbus-codegen )
  106. doc? ( dev-util/gi-docgen )
  107. "
  108. S="${WORKDIR}/${MY_P}"
  109. CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
  110. pkg_pretend() {
  111. if [[ ${MERGE_TYPE} != "binary" ]] ; then
  112. if is-flagq "-g*" && ! is-flagq "-g*0" ; then
  113. einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
  114. check-reqs_pkg_pretend
  115. fi
  116. if ! test-flag-CXX -std=c++17 ; then
  117. die "You need at least GCC 7.3.x or Clang >= 5 for C++17-specific compiler flags"
  118. fi
  119. fi
  120. }
  121. pkg_setup() {
  122. if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
  123. check-reqs_pkg_setup
  124. fi
  125. python-any-r1_pkg_setup
  126. }
  127. src_prepare() {
  128. cmake_src_prepare
  129. gnome2_src_prepare
  130. }
  131. src_configure() {
  132. # Respect CC, otherwise fails on prefix #395875
  133. tc-export CC
  134. # WebkitGTK doesn't likes -D_FORTIFY_SOURCE=2
  135. #strip-flags
  136. #filter-flags "-D_FORTIFY_SOURCE=*"
  137. # https://bugs.webkit.org/show_bug.cgi?id=278883
  138. filter-flags '-ftrapv'
  139. # It does not compile on alpha without this in LDFLAGS
  140. # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
  141. use alpha && append-ldflags "-Wl,--no-relax"
  142. # Sigbuses on SPARC with mcpu and co., bug #???
  143. use sparc && filter-flags "-mvis"
  144. # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
  145. use ppc64 && append-flags "-mminimal-toc"
  146. # Try to use less memory, bug #469942 (see Fedora .spec for reference)
  147. append-ldflags $(test-flags-CCLD "-Wl,--no-keep-memory")
  148. # Ruby situation is a bit complicated. See bug 513888
  149. local rubyimpl
  150. local ruby_interpreter=""
  151. local RUBY
  152. for rubyimpl in ${USE_RUBY}; do
  153. if has_version -b "virtual/rubygems[ruby_targets_${rubyimpl}(-)]"; then
  154. RUBY="$(type -P ${rubyimpl})"
  155. ruby_interpreter="-DRUBY_EXECUTABLE=${RUBY}"
  156. fi
  157. done
  158. # This will rarely occur. Only a couple of corner cases could lead us to
  159. # that failure. See bug 513888
  160. [[ -z ${ruby_interpreter} ]] && die "No suitable ruby interpreter found"
  161. # JavaScriptCore/Scripts/postprocess-asm invokes another Ruby script directly
  162. # so it doesn't respect RUBY_EXECUTABLE, bug #771744.
  163. sed -i -e "s:#!/usr/bin/env ruby:#!${RUBY}:" $(grep -rl "/usr/bin/env ruby" Source/JavaScriptCore || die) || die
  164. # TODO: Check Web Audio support
  165. # should somehow let user select between them?
  166. local mycmakeargs=(
  167. ${ruby_interpreter}
  168. # If bubblewrap[suid] then portage makes it go-r and cmake find_program fails with that
  169. -DBWRAP_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/bwrap
  170. -DDBUS_PROXY_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/xdg-dbus-proxy
  171. -DPORT=GTK
  172. # Source/cmake/WebKitFeatures.cmake
  173. -DENABLE_API_TESTS=OFF
  174. -DENABLE_BUBBLEWRAP_SANDBOX=$(usex seccomp)
  175. -DENABLE_GAMEPAD=$(usex gamepad)
  176. -DENABLE_GEOLOCATION=$(usex dbus) # Runtime optional (talks over dbus service)
  177. -DENABLE_MINIBROWSER=$(usex examples)
  178. -DENABLE_PDFJS=$(usex pdf)
  179. -DSHOULD_INSTALL_JS_SHELL=$(usex examples)
  180. -DENABLE_SPELLCHECK=$(usex spell)
  181. -DENABLE_UNIFIED_BUILDS=$(usex jumbo-build)
  182. -DENABLE_VIDEO=$(usex gstreamer)
  183. -DENABLE_WEBGL=ON
  184. -DENABLE_WEB_AUDIO=$(usex gstreamer)
  185. -DENABLE_WEBDRIVER=OFF
  186. # Source/cmake/OptionsGTK.cmake
  187. -DUSE_LIBBACKTRACE=OFF
  188. -DENABLE_DOCUMENTATION=$(usex doc)
  189. -DENABLE_INTROSPECTION=$(usex introspection)
  190. -DENABLE_JOURNALD_LOG=$(usex systemd)
  191. -DENABLE_QUARTZ_TARGET=$(usex aqua)
  192. -DENABLE_WAYLAND_TARGET=$(usex wayland)
  193. -DENABLE_WEB_RTC=$(usex webrtc)
  194. -DENABLE_MEDIA_STREAM=$(usex webrtc)
  195. -DENABLE_X11_TARGET=$(usex X)
  196. -DUSE_GBM=ON
  197. #-DUSE_ANGLE_WEBGL=OFF
  198. -DUSE_AVIF=$(usex avif)
  199. -DUSE_GTK4=OFF
  200. -DUSE_JPEGXL=$(usex jpegxl)
  201. -DUSE_LCMS=$(usex lcms)
  202. -DUSE_LIBHYPHEN=ON
  203. -DUSE_LIBSECRET=$(usex keyring)
  204. -DUSE_SOUP2=ON
  205. -DUSE_WOFF2=ON
  206. -DUSE_SYSTEM_SYSPROF_CAPTURE=$(usex sysprof)
  207. )
  208. # https://bugs.gentoo.org/761238
  209. append-cppflags -DNDEBUG
  210. WK_USE_CCACHE=NO cmake_src_configure
  211. }
  212. pkg_postinst() {
  213. use dbus && optfeature "geolocation service (used at runtime if available)" "app-misc/geoclue"
  214. optfeature "Common Multimedia codecs" "media-plugins/gst-plugins-meta"
  215. optfeature "(MPEG-)DASH support" "media-plugins/gst-plugins-dash"
  216. optfeature "HTTP-Live-Streaming support" "media-plugins/gst-plugins-hls"
  217. }