logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

webkit-gtk-2.44.4-r600.ebuild (7202B)


  1. # Copyright 1999-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CMAKE_MAKEFILE_GENERATOR="ninja"
  5. PYTHON_REQ_USE="xml(+)"
  6. PYTHON_COMPAT=( python3_{10..12} )
  7. USE_RUBY="ruby30 ruby31 ruby32 ruby33"
  8. inherit check-reqs flag-o-matic gnome2 optfeature python-any-r1 ruby-single toolchain-funcs cmake
  9. MY_P="webkitgtk-${PV}"
  10. DESCRIPTION="Open source web browser engine"
  11. HOMEPAGE="https://www.webkitgtk.org"
  12. SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
  13. # Apache-2.0 for fast_float, ANGLE (also pdfjs but disabled)
  14. # See https://bugs.webkit.org/show_bug.cgi?id=254717
  15. LICENSE="LGPL-2+ BSD Apache-2.0"
  16. SLOT="6/0" # soname version of libwebkit2gtk-6.0
  17. KEYWORDS="~amd64 ~arm64"
  18. IUSE="aqua +avif dbus doc examples gamepad keyring +gstreamer +introspection pdf jpegxl +jumbo-build lcms +seccomp speech spell systemd wayland webrtc +X"
  19. REQUIRED_USE="
  20. doc? ( introspection )
  21. webrtc? ( gstreamer )
  22. || ( aqua wayland X )
  23. "
  24. # Dependencies found at Source/cmake/OptionsGTK.cmake
  25. RDEPEND="
  26. >=x11-libs/cairo-1.16.0:=[X?]
  27. >=media-libs/fontconfig-2.13.0:1.0
  28. >=media-libs/freetype-2.9.0:2
  29. >=dev-libs/libgcrypt-1.7.0:0=
  30. >=gui-libs/gtk-4.4.0:4[introspection?]
  31. >=media-libs/harfbuzz-1.4.2:=[icu(+)]
  32. >=dev-libs/icu-61.2:=
  33. media-libs/libjpeg-turbo:0=
  34. >=media-libs/libepoxy-1.4.0
  35. >=net-libs/libsoup-2.99.9:3.0[introspection?]
  36. >=dev-libs/libxml2-2.8.0:2
  37. >=media-libs/libpng-1.4:0=
  38. dev-db/sqlite:3=
  39. sys-libs/zlib:0
  40. >=dev-libs/atk-2.16.0[introspection?]
  41. media-libs/libwebp:=
  42. >=dev-libs/glib-2.70.0:2
  43. >=dev-libs/libxslt-1.1.7
  44. media-libs/woff2
  45. keyring? ( app-crypt/libsecret )
  46. introspection? ( >=dev-libs/gobject-introspection-1.59.1:= )
  47. dev-libs/libtasn1:=
  48. spell? ( >=app-text/enchant-0.22:2 )
  49. gstreamer? (
  50. >=media-libs/gstreamer-1.20:1.0
  51. >=media-libs/gst-plugins-base-1.20:1.0[egl,X?]
  52. media-libs/gst-plugins-base:1.0[opengl]
  53. >=media-plugins/gst-plugins-opus-1.20:1.0
  54. >=media-libs/gst-plugins-bad-1.20:1.0[X?]
  55. )
  56. webrtc? (
  57. media-plugins/gst-plugins-webrtc:1.0
  58. >=dev-libs/openssl-3:=
  59. )
  60. X? (
  61. x11-libs/libX11
  62. x11-libs/libXcomposite
  63. x11-libs/libXdamage
  64. x11-libs/libXrender
  65. x11-libs/libXt
  66. )
  67. dev-libs/hyphen
  68. jpegxl? ( media-libs/libjxl )
  69. avif? ( >=media-libs/libavif-0.9.0:= )
  70. lcms? ( media-libs/lcms:2 )
  71. media-libs/mesa
  72. media-libs/libglvnd
  73. wayland? (
  74. >=dev-libs/wayland-1.15
  75. >=dev-libs/wayland-protocols-1.15
  76. )
  77. seccomp? (
  78. >=sys-apps/bubblewrap-0.3.1
  79. sys-libs/libseccomp
  80. sys-apps/xdg-dbus-proxy
  81. )
  82. speech? ( app-accessibility/flite )
  83. systemd? ( sys-apps/systemd:= )
  84. gamepad? ( >=dev-libs/libmanette-0.2.4 )
  85. "
  86. DEPEND="${RDEPEND}"
  87. # Need real bison, not yacc
  88. BDEPEND="
  89. ${PYTHON_DEPS}
  90. ${RUBY_DEPS}
  91. dev-util/glib-utils
  92. >=dev-util/gperf-3.0.1
  93. dev-util/unifdef
  94. >=sys-devel/bison-2.4.3
  95. || ( >=sys-devel/gcc-7.3 >=sys-devel/clang-5 )
  96. sys-devel/gettext
  97. virtual/pkgconfig
  98. >=dev-lang/perl-5.10
  99. virtual/perl-Data-Dumper
  100. virtual/perl-Carp
  101. virtual/perl-JSON-PP
  102. dbus? ( dev-util/gdbus-codegen )
  103. doc? ( dev-util/gi-docgen )
  104. "
  105. S="${WORKDIR}/${MY_P}"
  106. CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
  107. pkg_pretend() {
  108. if [[ ${MERGE_TYPE} != "binary" ]] ; then
  109. if is-flagq "-g*" && ! is-flagq "-g*0" ; then
  110. einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
  111. check-reqs_pkg_pretend
  112. fi
  113. if ! test-flag-CXX -std=c++17 ; then
  114. die "You need at least GCC 7.3.x or Clang >= 5 for C++17-specific compiler flags"
  115. fi
  116. fi
  117. }
  118. pkg_setup() {
  119. if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
  120. check-reqs_pkg_setup
  121. fi
  122. python-any-r1_pkg_setup
  123. }
  124. src_prepare() {
  125. cmake_src_prepare
  126. gnome2_src_prepare
  127. }
  128. src_configure() {
  129. # Respect CC, otherwise fails on prefix #395875
  130. tc-export CC
  131. # WebkitGTK doesn't likes -D_FORTIFY_SOURCE=2
  132. #strip-flags
  133. #filter-flags "-D_FORTIFY_SOURCE=*"
  134. # https://bugs.webkit.org/show_bug.cgi?id=278883
  135. filter-flags '-ftrapv'
  136. # It does not compile on alpha without this in LDFLAGS
  137. # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
  138. use alpha && append-ldflags "-Wl,--no-relax"
  139. # Sigbuses on SPARC with mcpu and co., bug #???
  140. use sparc && filter-flags "-mvis"
  141. # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
  142. use ppc64 && append-flags "-mminimal-toc"
  143. # Try to use less memory, bug #469942 (see Fedora .spec for reference)
  144. append-ldflags $(test-flags-CCLD "-Wl,--no-keep-memory")
  145. # Ruby situation is a bit complicated. See bug 513888
  146. local rubyimpl
  147. local ruby_interpreter=""
  148. local RUBY
  149. for rubyimpl in ${USE_RUBY}; do
  150. if has_version -b "virtual/rubygems[ruby_targets_${rubyimpl}(-)]"; then
  151. RUBY="$(type -P ${rubyimpl})"
  152. ruby_interpreter="-DRUBY_EXECUTABLE=${RUBY}"
  153. fi
  154. done
  155. # This will rarely occur. Only a couple of corner cases could lead us to
  156. # that failure. See bug 513888
  157. [[ -z ${ruby_interpreter} ]] && die "No suitable ruby interpreter found"
  158. # JavaScriptCore/Scripts/postprocess-asm invokes another Ruby script directly
  159. # so it doesn't respect RUBY_EXECUTABLE, bug #771744.
  160. sed -i -e "s:#!/usr/bin/env ruby:#!${RUBY}:" $(grep -rl "/usr/bin/env ruby" Source/JavaScriptCore || die) || die
  161. # TODO: Check Web Audio support
  162. # should somehow let user select between them?
  163. local mycmakeargs=(
  164. ${ruby_interpreter}
  165. # If bubblewrap[suid] then portage makes it go-r and cmake find_program fails with that
  166. -DBWRAP_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/bwrap
  167. -DDBUS_PROXY_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/xdg-dbus-proxy
  168. -DPORT=GTK
  169. # Source/cmake/WebKitFeatures.cmake
  170. -DENABLE_API_TESTS=OFF
  171. -DENABLE_BUBBLEWRAP_SANDBOX=$(usex seccomp)
  172. -DENABLE_GAMEPAD=$(usex gamepad)
  173. -DENABLE_GEOLOCATION=$(usex dbus) # Runtime optional (talks over dbus service)
  174. -DENABLE_MINIBROWSER=$(usex examples)
  175. -DENABLE_PDFJS=$(usex pdf)
  176. -DSHOULD_INSTALL_JS_SHELL=$(usex examples)
  177. -DENABLE_SPELLCHECK=$(usex spell)
  178. -DENABLE_SPEECH_SYNTHESIS=$(usex speech)
  179. -DENABLE_UNIFIED_BUILDS=$(usex jumbo-build)
  180. -DENABLE_VIDEO=$(usex gstreamer)
  181. -DENABLE_WEBGL=ON
  182. -DENABLE_WEB_AUDIO=$(usex gstreamer)
  183. -DENABLE_WEBDRIVER=OFF
  184. # Source/cmake/OptionsGTK.cmake
  185. -DUSE_LIBBACKTRACE=OFF
  186. -DENABLE_DOCUMENTATION=$(usex doc)
  187. -DENABLE_INTROSPECTION=$(usex introspection)
  188. -DENABLE_JOURNALD_LOG=$(usex systemd)
  189. -DENABLE_QUARTZ_TARGET=$(usex aqua)
  190. -DENABLE_WAYLAND_TARGET=$(usex wayland)
  191. -DENABLE_WEB_RTC=$(usex webrtc)
  192. -DENABLE_MEDIA_STREAM=$(usex webrtc)
  193. -DENABLE_X11_TARGET=$(usex X)
  194. -DUSE_GBM=ON
  195. #-DUSE_ANGLE_WEBGL=OFF
  196. -DUSE_AVIF=$(usex avif)
  197. -DUSE_GTK4=ON
  198. -DUSE_JPEGXL=$(usex jpegxl)
  199. -DUSE_LCMS=$(usex lcms)
  200. -DUSE_LIBHYPHEN=ON
  201. -DUSE_LIBSECRET=$(usex keyring)
  202. -DUSE_SOUP2=OFF
  203. -DUSE_WOFF2=ON
  204. )
  205. # https://bugs.gentoo.org/761238
  206. append-cppflags -DNDEBUG
  207. WK_USE_CCACHE=NO cmake_src_configure
  208. }
  209. src_test() {
  210. eninja -C "${BUILD_DIR?}" check
  211. }
  212. pkg_postinst() {
  213. use dbus && optfeature "geolocation service (used at runtime if available)" "app-misc/geoclue"
  214. optfeature "Common Multimedia codecs" "media-plugins/gst-plugins-meta"
  215. optfeature "(MPEG-)DASH support" "media-plugins/gst-plugins-dash"
  216. optfeature "HTTP-Live-Streaming support" "media-plugins/gst-plugins-hls"
  217. }