logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

webkit-gtk-2.44.1-r410.ebuild (7326B)


  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CMAKE_MAKEFILE_GENERATOR="ninja"
  5. PYTHON_REQ_USE="xml(+)"
  6. PYTHON_COMPAT=( python3_{10..12} )
  7. USE_RUBY="ruby30 ruby31 ruby32 ruby33"
  8. inherit check-reqs flag-o-matic gnome2 optfeature python-any-r1 ruby-single toolchain-funcs cmake
  9. MY_P="webkitgtk-${PV}"
  10. DESCRIPTION="Open source web browser engine"
  11. HOMEPAGE="https://www.webkitgtk.org"
  12. SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
  13. # Apache-2.0 for fast_float, ANGLE (also pdfjs but disabled)
  14. # See https://bugs.webkit.org/show_bug.cgi?id=254717
  15. LICENSE="LGPL-2+ BSD Apache-2.0"
  16. SLOT="4.1/0" # soname version of libwebkit2gtk-4.1
  17. KEYWORDS="~amd64 ~arm64"
  18. IUSE="aqua +avif dbus doc examples gamepad keyring +gstreamer +introspection pdf jpegxl +jumbo-build lcms +seccomp spell systemd wayland webrtc +X"
  19. REQUIRED_USE="
  20. doc? ( introspection )
  21. webrtc? ( gstreamer )
  22. || ( aqua wayland X )
  23. "
  24. # Tests are currently unsupported in release tarballs
  25. # https://bugs.webkit.org/show_bug.cgi?id=215986
  26. RESTRICT="test"
  27. # Dependencies found at Source/cmake/OptionsGTK.cmake
  28. RDEPEND="
  29. >=x11-libs/cairo-1.16.0:=[X?]
  30. >=media-libs/fontconfig-2.13.0:1.0
  31. >=media-libs/freetype-2.9.0:2
  32. >=dev-libs/libgcrypt-1.7.0:0=
  33. >=x11-libs/gtk+-3.22.0:3[aqua?,introspection?,wayland?,X?]
  34. >=media-libs/harfbuzz-1.4.2:=[icu(+)]
  35. >=dev-libs/icu-61.2:=
  36. media-libs/libjpeg-turbo:0=
  37. >=media-libs/libepoxy-1.4.0
  38. >=net-libs/libsoup-2.99.9:3.0[introspection?]
  39. >=dev-libs/libxml2-2.8.0:2
  40. >=media-libs/libpng-1.4:0=
  41. dev-db/sqlite:3=
  42. sys-libs/zlib:0
  43. >=dev-libs/atk-2.16.0[introspection?]
  44. media-libs/libwebp:=
  45. >=dev-libs/glib-2.70.0:2
  46. >=dev-libs/libxslt-1.1.7
  47. media-libs/woff2
  48. keyring? ( app-crypt/libsecret )
  49. introspection? ( >=dev-libs/gobject-introspection-1.59.1:= )
  50. dev-libs/libtasn1:=
  51. spell? ( >=app-text/enchant-0.22:2 )
  52. gstreamer? (
  53. >=media-libs/gstreamer-1.20:1.0
  54. >=media-libs/gst-plugins-base-1.20:1.0[egl,X?]
  55. media-libs/gst-plugins-base:1.0[opengl]
  56. >=media-plugins/gst-plugins-opus-1.20:1.0
  57. >=media-libs/gst-plugins-bad-1.20:1.0[X?]
  58. )
  59. webrtc? (
  60. media-plugins/gst-plugins-webrtc:1.0
  61. >=dev-libs/openssl-3:=
  62. )
  63. X? (
  64. x11-libs/libX11
  65. x11-libs/libXcomposite
  66. x11-libs/libXdamage
  67. x11-libs/libXrender
  68. x11-libs/libXt
  69. )
  70. dev-libs/hyphen
  71. jpegxl? ( media-libs/libjxl )
  72. avif? ( >=media-libs/libavif-0.9.0:= )
  73. lcms? ( media-libs/lcms:2 )
  74. media-libs/mesa
  75. media-libs/libglvnd
  76. wayland? (
  77. >=dev-libs/wayland-1.15
  78. >=dev-libs/wayland-protocols-1.15
  79. )
  80. seccomp? (
  81. >=sys-apps/bubblewrap-0.3.1
  82. sys-libs/libseccomp
  83. sys-apps/xdg-dbus-proxy
  84. )
  85. systemd? ( sys-apps/systemd:= )
  86. gamepad? ( >=dev-libs/libmanette-0.2.4 )
  87. "
  88. DEPEND="${RDEPEND}"
  89. # Need real bison, not yacc
  90. BDEPEND="
  91. ${PYTHON_DEPS}
  92. ${RUBY_DEPS}
  93. dev-util/glib-utils
  94. >=dev-util/gperf-3.0.1
  95. dev-util/unifdef
  96. >=sys-devel/bison-2.4.3
  97. || ( >=sys-devel/gcc-7.3 >=sys-devel/clang-5 )
  98. sys-devel/gettext
  99. virtual/pkgconfig
  100. >=dev-lang/perl-5.10
  101. virtual/perl-Data-Dumper
  102. virtual/perl-Carp
  103. virtual/perl-JSON-PP
  104. dbus? ( dev-util/gdbus-codegen )
  105. doc? ( dev-util/gi-docgen )
  106. "
  107. S="${WORKDIR}/${MY_P}"
  108. CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
  109. pkg_pretend() {
  110. if [[ ${MERGE_TYPE} != "binary" ]] ; then
  111. if is-flagq "-g*" && ! is-flagq "-g*0" ; then
  112. einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
  113. check-reqs_pkg_pretend
  114. fi
  115. if ! test-flag-CXX -std=c++17 ; then
  116. die "You need at least GCC 7.3.x or Clang >= 5 for C++17-specific compiler flags"
  117. fi
  118. fi
  119. }
  120. pkg_setup() {
  121. if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
  122. check-reqs_pkg_setup
  123. fi
  124. python-any-r1_pkg_setup
  125. }
  126. src_prepare() {
  127. cmake_src_prepare
  128. gnome2_src_prepare
  129. }
  130. src_configure() {
  131. # Respect CC, otherwise fails on prefix #395875
  132. tc-export CC
  133. # WebkitGTK doesn't likes -D_FORTIFY_SOURCE=2
  134. #strip-flags
  135. #filter-flags "-D_FORTIFY_SOURCE=*"
  136. # It does not compile on alpha without this in LDFLAGS
  137. # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
  138. use alpha && append-ldflags "-Wl,--no-relax"
  139. # ld segfaults on ia64 with LDFLAGS --as-needed, bug #555504
  140. use ia64 && append-ldflags "-Wl,--no-as-needed"
  141. # Sigbuses on SPARC with mcpu and co., bug #???
  142. use sparc && filter-flags "-mvis"
  143. # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
  144. use ppc64 && append-flags "-mminimal-toc"
  145. # Try to use less memory, bug #469942 (see Fedora .spec for reference)
  146. # --no-keep-memory doesn't work on ia64, bug #502492
  147. if ! use ia64; then
  148. append-ldflags $(test-flags-CCLD "-Wl,--no-keep-memory")
  149. fi
  150. # Ruby situation is a bit complicated. See bug 513888
  151. local rubyimpl
  152. local ruby_interpreter=""
  153. local RUBY
  154. for rubyimpl in ${USE_RUBY}; do
  155. if has_version -b "virtual/rubygems[ruby_targets_${rubyimpl}(-)]"; then
  156. RUBY="$(type -P ${rubyimpl})"
  157. ruby_interpreter="-DRUBY_EXECUTABLE=${RUBY}"
  158. fi
  159. done
  160. # This will rarely occur. Only a couple of corner cases could lead us to
  161. # that failure. See bug 513888
  162. [[ -z ${ruby_interpreter} ]] && die "No suitable ruby interpreter found"
  163. # JavaScriptCore/Scripts/postprocess-asm invokes another Ruby script directly
  164. # so it doesn't respect RUBY_EXECUTABLE, bug #771744.
  165. sed -i -e "s:#!/usr/bin/env ruby:#!${RUBY}:" $(grep -rl "/usr/bin/env ruby" Source/JavaScriptCore || die) || die
  166. # TODO: Check Web Audio support
  167. # should somehow let user select between them?
  168. local mycmakeargs=(
  169. ${ruby_interpreter}
  170. # If bubblewrap[suid] then portage makes it go-r and cmake find_program fails with that
  171. -DBWRAP_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/bwrap
  172. -DDBUS_PROXY_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/xdg-dbus-proxy
  173. -DPORT=GTK
  174. # Source/cmake/WebKitFeatures.cmake
  175. -DENABLE_API_TESTS=OFF
  176. -DENABLE_BUBBLEWRAP_SANDBOX=$(usex seccomp)
  177. -DENABLE_GAMEPAD=$(usex gamepad)
  178. -DENABLE_GEOLOCATION=$(usex dbus) # Runtime optional (talks over dbus service)
  179. -DENABLE_MINIBROWSER=$(usex examples)
  180. -DENABLE_PDFJS=$(usex pdf)
  181. -DSHOULD_INSTALL_JS_SHELL=$(usex examples)
  182. -DENABLE_SPELLCHECK=$(usex spell)
  183. -DENABLE_UNIFIED_BUILDS=$(usex jumbo-build)
  184. -DENABLE_VIDEO=$(usex gstreamer)
  185. -DENABLE_WEBGL=ON
  186. -DENABLE_WEB_AUDIO=$(usex gstreamer)
  187. -DENABLE_WEBDRIVER=OFF
  188. # Source/cmake/OptionsGTK.cmake
  189. -DUSE_LIBBACKTRACE=OFF
  190. -DENABLE_DOCUMENTATION=$(usex doc)
  191. -DENABLE_INTROSPECTION=$(usex introspection)
  192. -DENABLE_JOURNALD_LOG=$(usex systemd)
  193. -DENABLE_QUARTZ_TARGET=$(usex aqua)
  194. -DENABLE_WAYLAND_TARGET=$(usex wayland)
  195. -DENABLE_WEB_RTC=$(usex webrtc)
  196. -DENABLE_MEDIA_STREAM=$(usex webrtc)
  197. -DENABLE_X11_TARGET=$(usex X)
  198. -DUSE_GBM=ON
  199. #-DUSE_ANGLE_WEBGL=OFF
  200. -DUSE_AVIF=$(usex avif)
  201. -DUSE_GTK4=OFF
  202. -DUSE_JPEGXL=$(usex jpegxl)
  203. -DUSE_LCMS=$(usex lcms)
  204. -DUSE_LIBHYPHEN=ON
  205. -DUSE_LIBSECRET=$(usex keyring)
  206. -DUSE_SOUP2=OFF
  207. -DUSE_WOFF2=ON
  208. )
  209. # https://bugs.gentoo.org/761238
  210. append-cppflags -DNDEBUG
  211. WK_USE_CCACHE=NO cmake_src_configure
  212. }
  213. pkg_postinst() {
  214. use dbus && optfeature "geolocation service (used at runtime if available)" "app-misc/geoclue"
  215. optfeature "Common Multimedia codecs" "media-plugins/gst-plugins-meta"
  216. optfeature "(MPEG-)DASH support" "media-plugins/gst-plugins-dash"
  217. optfeature "HTTP-Live-Streaming support" "media-plugins/gst-plugins-hls"
  218. }