logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libsoup-3.0.8.ebuild (3141B)


  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. VALA_MIN_API_VERSION="0.54" # requires gio-2.0.vapi generated from glib-2.70+
  5. inherit gnome.org meson-multilib vala xdg
  6. DESCRIPTION="HTTP client/server library for GNOME"
  7. HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
  8. LICENSE="LGPL-2.1+"
  9. SLOT="3.0"
  10. IUSE="+brotli gssapi gtk-doc +introspection samba ssl sysprof test +vala"
  11. RESTRICT="!test? ( test )"
  12. REQUIRED_USE="vala? ( introspection )"
  13. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
  14. DEPEND="
  15. >=dev-libs/glib-2.69.1:2[${MULTILIB_USEDEP}]
  16. net-libs/nghttp2:=[${MULTILIB_USEDEP}]
  17. >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
  18. brotli? ( >=app-arch/brotli-1.0.6-r1:=[${MULTILIB_USEDEP}] )
  19. >=net-libs/libpsl-0.20[${MULTILIB_USEDEP}]
  20. sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
  21. sys-libs/zlib
  22. gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
  23. introspection? ( >=dev-libs/gobject-introspection-1.54:= )
  24. samba? ( net-fs/samba )
  25. "
  26. RDEPEND="${DEPEND}
  27. >=net-libs/glib-networking-2.70_alpha[ssl?,${MULTILIB_USEDEP}]
  28. "
  29. BDEPEND="
  30. dev-libs/glib
  31. dev-util/glib-utils
  32. gtk-doc? ( >=dev-util/gtk-doc-1.20
  33. app-text/docbook-xml-dtd:4.1.2 )
  34. >=sys-devel/gettext-0.19.8
  35. virtual/pkgconfig
  36. vala? ( $(vala_depend) )
  37. test? ( >=net-libs/gnutls-3.6.0[pkcs11] )
  38. "
  39. # test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
  40. # apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
  41. # apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
  42. # dev-lang/php[apache2,xmlrpc]
  43. # net-misc/curl
  44. # net-libs/glib-networking[ssl])"
  45. PATCHES=(
  46. # Disable apache tests until they are usable on Gentoo, bug #326957
  47. "${FILESDIR}"/disable-apache-tests.patch
  48. )
  49. src_prepare() {
  50. default
  51. use vala && vala_setup
  52. xdg_environment_reset
  53. # https://gitlab.gnome.org/GNOME/libsoup/issues/159 - could work with libnss-myhostname
  54. sed -e '/hsts/d' -i tests/meson.build || die
  55. }
  56. src_configure() {
  57. # FIXME: we need addpredict to workaround bug #324779 until
  58. # root cause (bug #249496) is solved
  59. # But unnecessary while apache tests are disabled
  60. #addpredict /usr/share/snmp/mibs/.index
  61. multilib-minimal_src_configure
  62. }
  63. multilib_src_configure() {
  64. local emesonargs=(
  65. # Avoid auto-magic, built-in feature of meson
  66. -Dauto_features=enabled
  67. $(meson_feature gssapi)
  68. -Dkrb5_config="${CHOST}-krb5-config"
  69. $(meson_feature samba ntlm)
  70. $(meson_feature brotli)
  71. -Dntlm_auth="${EPREFIX}/usr/bin/ntlm_auth"
  72. -Dtls_check=false # disables check, we still rdep on glib-networking
  73. $(meson_native_use_feature introspection)
  74. $(meson_native_use_feature vala vapi)
  75. $(meson_native_use_bool gtk-doc gtk_doc)
  76. $(meson_use test tests)
  77. -Dinstalled_tests=false
  78. -Dhttp2_tests=disabled # quart is absent from gentoo repo
  79. -Dautobahn=disabled # autobahn depends on py-cryptography which depends on Rust
  80. $(meson_feature sysprof)
  81. $(meson_feature test pkcs11_tests)
  82. )
  83. meson_src_configure
  84. }